1. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice
  2. Unity 5.6 is now released.
    Dismiss Notice
  3. Check out all the fixes for 5.5 in patch releases 1 & 2.
    Dismiss Notice
  4. Get further faster with the Unity Plus Accelerator Pack, free for new Unity Plus subscribers for a limited time. Click here for more details.
    Dismiss Notice
  5. Learn how you'll soon be able to publish your games to China in four simple steps with Xiaomi. Sign up now for early access.
    Dismiss Notice

EasyRoads3D v3 - the upcoming new road system

Discussion in 'Works In Progress' started by raoul, Feb 19, 2014.

  1. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi Michael,

    Thank you, glad you like it!

    The Road Network position is indeed locked. This is done to avoid situations where it is moved several times and possible unwantedly therefor you may no longer know the original position resulting in the roads no longer matching the terrain.

    An option to move the entire Road network deliberately can be added, it hasn't been requested before :). Meanwhile, if you know exactly to where to move the road network, this can be done through the scripting API. Go through all connections, move each connection according the position change, go through all roads and move all markers according the position change.

    Thanks,
    Raoul
     
  2. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi Cezar,

    Your write that you didn't change anything but you also write that you modified it in the "Open Mesh Window"? What is the bug you want to report?

    It sounds like you changed settings in the Mesh Editor window? What did you change? Can you show a screenshot? Or can you import the package in a new project so you can compare the default settings for this bridge side object with your current settings?

    One of the options you have in the Mesh Editor Window is specifying offsets how a specific procedural side object should adjust to the different road widths. These offsets represent the left and right side of the road. This way bridges can auto adapt to the width of the road. It looks like you changed these settings for that specific bridge side object and therefore it doesn't nicely fit the road anymore.

    Thanks,
    Raoul
     
  3. Max1982

    Max1982

    Joined:
    Oct 16, 2014
    Posts:
    63

    Hi Raoul,

    I will check that offset settings. Thanks.
     
  4. DiegoDePalacio

    DiegoDePalacio

    Joined:
    Oct 28, 2009
    Posts:
    10
    Hi Raoul,

    I'm currently placing some buildings as side objects along the road, using the option of placing random prefab childs of a source object prefab.

    The problem that I'm facing now is that if the childs have different bounding box sizes in X-axis, I didn't found any option to place them with a distance between them, taking on account such boundaries.

    Is there any way in the editor options, to take on account the bounding box of the "childs" to place them?

    If not... Can I override the placement method in some way, to achieve the same result, with the current API?


    Thanks,

    Diego de Palacio.
     
  5. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi Cezar,

    It seems you removed your previous post. I guess this was indeed related to changed Road Width Offset values?

    Thanks,
    Raoul
     
  6. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi Diego,

    That side object type currently can only be placed at fixed or random distances. I will make a note to include an option based on the bounding box sizes.

    Probably you can do this relatively simply yourself since you already posted API code examples. You can use the spline data and instantiate objects based on the bounding box sizes. Cleverlie asked a similar question recently and was able to get it working, https://forum.unity3d.com/threads/e...g-new-road-system.229327/page-65#post-3001250

    Thanks,
    Raoul
     
  7. JOKaija

    JOKaija

    Joined:
    Feb 8, 2015
    Posts:
    153
    Hi!

    Long time since last visited here. Had a huge amount of other work to do.
    At last I can continue with my game project :)

    Any fancy addons on API?

    Fast sneek about game project with all bugs :oops:

     
  8. ManjitSBedi

    ManjitSBedi

    Joined:
    Mar 8, 2014
    Posts:
    13
    Hello,

    I have been trying out the free version of the EasyRoads3D - what a time saver!

    I am having a strange problem, the road seems to be rendered last or on top of the objects you could say. Is this something to do with the render queue? I have tried different values with no success. It could be something else.

    in the attached image, you can see the trees are drawn behind the road. The terrain object is flat with a green material. I am using the scene with the Google VR SDK (in case that is relevant). road render issue.png
     
  9. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi Jari,

    Looks like you have been busy, a lot of progress. :)

    The API is still build upon request. Some things might be added, I don't know the last time you used it.

    Thanks,
    Raoul
     
  10. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi ManjitSBedi,

    Glad to hear the free version has been useful for you!

    Is the screenshot taken with the road object in Edit Mode? By default V2 uses a shader in Edit Mode that draws the road on top of all other objects. This is especially for hilly areas, you can clearly see the shape of the final road whereas otherwise it will partially or completely disappear below the terrain. In Build Mode (the middle mountain tab) the terrain will be deformed according the road shape and the final road material is used.

    Also, the free version is still v2, this is the v3 thread :)

    Thanks,
    Raoul
     
  11. AurimasBlazulionis

    AurimasBlazulionis

    Joined:
    Aug 13, 2013
    Posts:
    171
    Hello, I have a couple of questions.
    There seems to be some problems in a built project (fine in the editor) with the texture tiling. On this highway road (it is quite long, probably over 10km) the textures stretch at some points.

    Also, sometimes the terrain still glitches out above the road. Also, due to the offset value being used in the shader the shadows falling on the road in a distance make it seem that the road is 1 meter above ground. Maybe there is a way to integrate the road using some RTP magic (just got it recently, did not play around with all options)?

    Just for the record, I used the beta 8.5 included in the v2 package.
     

    Attached Files:

  12. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hello AurimasBlazulionis,
    That looks like floating point inaccuracies on the UVs due to the long length of the road. You wrote that all is fine in the editor. For which platform build does this happen?

    In any case, this cannot be resolved for the road itself. But beta 8.5 includes a new I Connector option. When selecting a marker you will see an option "Insert I Connector" in the Inspector at the bottom of the marker section. This will split the road in segments. Select one of the markers just before this UV stretching occurs and press "Insert I Connector".That will probably resolve the issue.

    Can you show situations where the terrain glitches out above the road? The troubleshooting page covers possible causes and includes ways how to deal with it.

    Usually real time shadows are only visible nearby the cam, can you show a screenshot where this happens? What are the Offset values in the shader? It is impossible to add the road to the terrain. What RTP magic are you looking for? :) Another way to deal with z-fighting is extruded roads. This will be added to the dynamic crossing options in 3.x. Meanwhile you can achieve this by using custom road shapes based on imported prefabs. The provisional beta package main scene includes an example of a custom road network, the single lane road connected to the T crossing has an extruded shape.

    Thanks,
    Raoul
     
  13. AurimasBlazulionis

    AurimasBlazulionis

    Joined:
    Aug 13, 2013
    Posts:
    171
    RTP has options to blend objects with the terrain avoiding Z-fighting. But as I said before, I haven't had a chance yet to play with all the options. Extruded roads. Oh that is great! Because currently while driving a car sometimes the wheels collide with the terrain and not the road.

    Speaking of my first issues, I will try with the connector. I am building for windows 64-bit, the same happens in Linux build as well.

    The last 2 screenshots show the road glitching part. It does only when your camera is close.

    And the shadows problem is not that big of a deal, but the other screenshots can illustrate that. That is due to the "Offset -3, -3" in the shader, but I completely understand that it is the only way to make the terrain not clip through the road that often.

    Screenshots are here.
     
  14. AurimasBlazulionis

    AurimasBlazulionis

    Joined:
    Aug 13, 2013
    Posts:
    171
    Here is another screenshot showing how extreme the shadow problem can be. It is near the cursor.
     

    Attached Files:

  15. AurimasBlazulionis

    AurimasBlazulionis

    Joined:
    Aug 13, 2013
    Posts:
    171
    Also, my biggest complaint while working with the system would be that when you try to move a point and there is another one behind and the cursor is on it, it gets selected, instead of allowing to move the transform arrows of the already selected point.
     
  16. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Is that primarily a geometry blend tool or does it actually deal with real z-fighting?

    The terrain is flat, is that at the terrains game object Y position? Do you see red dots in edit mode? What happens when you raise the T crossing a little bit?

    Yes, it is a side affect but, I think, not really to the extend that it becomes a problem. It is not very noticeable nearby the cam, and your last screenshot where it is clearly visible (if you focus on it) uses a fairly high shadow distance in the guality settings. I am afraid there is not much that can be done about that, that is indeed how the Unity Offset implementation works. The alternative is raising the road network further above the ground or use extruded roads as mentioned before. But in that case, in hilly areas those far views may result in the road disappearing below the terrain when the terrains LOD system kicks in. That is the advantage of using these Offsets in the shader, it will be less likely the road disappears behind the terrain in that case.

    Yes, that can happen with more horizontal views and is annoying. I will see if that can be optimized further before the final release.

    Thanks,
    Raoul
     
  17. ManjitSBedi

    ManjitSBedi

    Joined:
    Mar 8, 2014
    Posts:
    13
    I see; my mistake for positing in the wrong forum. It does not work with the Google VR SDK for some reason. When displaying the scene on an iPhone, the road is drawn on top of everything else like in the screen shot from earlier.
     
  18. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi ManjitSBedi,

    No problem :), I also mentioned that because the free version, v2, cannot really be compared with v3.

    What is the problem with Google VR SDK? And is the problem on iPohne the same as the initial issue you wrote? Is the road object not in Edit Mode (see my previous reply)? Can you show a screenshot with the road selected and the Inspector clearly visible?

    Thanks,
    Raoul
     
  19. ManjitSBedi

    ManjitSBedi

    Joined:
    Mar 8, 2014
    Posts:
    13
    Hello Raoul.

    Thanks for your time.

    It might be worth mentioning, when I import the Easy Roads free package, there is a warning about obsolete API calls. I am using Unity 5.5.3 p1

    When I view the road in the editor it renders as you described; it also renders the same way whwn I select play in Unity.

    Here is a zoomed in screen shot with the app build natively on an iPhone using the Google VR SDK which is rendering the scene in stereo with a left & right camera.

    ios build detail.png

    and here is the inspector for the road object.


    inspector.png
     
    Last edited: Apr 15, 2017
  20. ManjitSBedi

    ManjitSBedi

    Joined:
    Mar 8, 2014
    Posts:
    13

    Hello Raoul,

    I bought the pro version of Easy Roads & started over; the problem has gone away.
     
    hopeful likes this.
  21. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi ManjitSBedi,

    Ok, glad to hear that is resolved :)

    Just to be sure, did you simply import the Por package? In that case you are still using v2. The v3 beta is included as a separate package in the /Assets/EasyRoads3D/ root directory. It will soon be released.

    As for the free version issue, the road material in the screenshot says, RoadMaterialEdit, this is indeed what I mentioned. It was using the Edit mode shader that forces the road to draw on top of all other objects so it is clearly visible in hilly areas in Edit Mode.

    Thanks,
    Raoul
     
  22. Max1982

    Max1982

    Joined:
    Oct 16, 2014
    Posts:
    63
    Hi Raoul,

    I changed offset values of bridge mesh in Open Mesh Window.
     
  23. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi Cezar,

    Thank you, that indeed does explain why the bridge sides were no longer nicely matching the road in the screenshot you posted last week.

    Raoul
     
  24. ManjitSBedi

    ManjitSBedi

    Joined:
    Mar 8, 2014
    Posts:
    13
    I deleted the old package & imported the beta package & made a new road object.
     
    raoul likes this.
  25. faqilah92

    faqilah92

    Joined:
    Apr 7, 2017
    Posts:
    7
    hello..good evening..
    i'm faqilah92 ..
    the Easyroads3d tool is very good..i like it..
    but i confusing watching the video,due to different version.
    do you have any video with latestly unity version?
    i have use the unity version 5.4.0f3 & 5.6.0f3

    another problem is..how can i remove the white box?
    Is't the right way to create rail?
    I will show you the example I do in microsoft word

    if you have the solution please show me..
    I really need your help to solve this problem

    TQVM
     

    Attached Files:

  26. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hello faqilah,

    The white surfaces define how the terrain will be flattened according the road objects. You can switch this off in General Settings > Scene Settings > Hide White Surfaces

    The screenshot only show the Scene View window and zoomed out. It is hard to tell from this picture only why the train rail is not visible. I don't see a connection object in the hierarchy. Did you create the track by choosing the train rail "road type"?

    Can you try dropping the custom prefab "Train Crossing Single Lane" in the scene and pull out a rail from the green handles?

    What are the differences for Unity 5.4 & 5.6. The videos are not 100% up to date, new features have been added but the general workflow is still the same. New videos will be made once it is out of beta.

    Thanks,
    Raoul
     
    Last edited: Apr 17, 2017
  27. faqilah92

    faqilah92

    Joined:
    Apr 7, 2017
    Posts:
    7
    my Boss want i to do the train rail without use "Train Crossing Single Lane" .he just want train rail only ..he want i do double train rail..how to do?
    hqdefault.jpg
     
  28. faqilah92

    faqilah92

    Joined:
    Apr 7, 2017
    Posts:
    7
    i'm trying hide the white surface..
    but why the train rail look like this..? train rail.PNG
    why train rail do not look like a road... the road look like a the true road..
     
  29. f1b0n4cc1

    f1b0n4cc1

    Joined:
    Aug 27, 2015
    Posts:
    33
    did you try build terrain button under build settings ? there is Raise Road network too which you can adjust road height
     
  30. faqilah92

    faqilah92

    Joined:
    Apr 7, 2017
    Posts:
    7
    how to do?
    can i get the tutorial or document how to do from the beginning..
    I have learned own without any guidance
    that's why I do not really know about the unity
    anyone can help me & guidance me..
     
  31. f1b0n4cc1

    f1b0n4cc1

    Joined:
    Aug 27, 2015
    Posts:
    33
    you can learn unity from tutorials here
     
  32. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    I only suggested using the "Train Crossing Single Lane" as a different way to create a rail object. And you can always remove the connection prefab itself afterwards if you do not want to use it. This way the end result is the rail track only :)

    I just tested creating a new Rail Road from the 2nd tab by selecting the Train Rail "road type". I got the same results as in your last screenshot. I will check why that happens.

    But the following next steps worked for me:

    1. Select the rail track
    2. In the Inspector you see the Road Type dropdown near the top. Select another road type and afterwards reselect the "Rail Road" road type.

    The rail track should look as expected now.

    A double rail can be done by using a connection prefab that includes two rails. EasyRoads3D is not a fully featured train rail system. Train rails can be simulated using custom prefabs. "Roads" pulled out of these custom prefabs will inherit the shape of the connection and you can create new "road types" from these connections.

    So, to create a double train rail you can use the "Train Crossing Single Lane" as an example. Build your double rail version from it and import it in the system like done in the below video:



    Thanks,
    Raoul
     
    Last edited: Apr 18, 2017
  33. faqilah92

    faqilah92

    Joined:
    Apr 7, 2017
    Posts:
    7
    okay thank you Raoul..
    i will try now..
    anything i didn't know...
    i will ask you again
     
  34. lboadle

    lboadle

    Joined:
    Nov 22, 2016
    Posts:
    2
    Quick question: Is it possible to use an alpha setting other than 'Cutout'? I am trying to create a dirt road that fades into the terrain, but using Diffuse instead of Cutout the road to ignore vehicle shadows than fall onto it.

    Thanks.
     
  35. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi lboadle,

    Full transparent shaders and shadows in Unity has been a topic for many years. We look at this all the time but I don't think it is supported yet. If you search around, also on the wiki pages, you will find some shaders but with limitations.

    The final v3 package will include some additional, more complex, shaders like used in the below screenshot.
    ERBikeTrack.jpg

    The actual terrain is flat, the geometry on the sides of the track is blended with the terrain using the terrain splatmap. It does receive shadows. A similar approach could be used to blend a dirt road with the terrain and still receive shadows.

    Thanks,
    Raoul
     
    christoph_r likes this.
  36. lboadle

    lboadle

    Joined:
    Nov 22, 2016
    Posts:
    2
    Thanks for the clarification, Raoul!
     
  37. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    The shader used in the above screenshot does actually already work with the Fade In / Fade Out options in the Inspector.

    Fade in and shadows.
    [​IMG]

    Thanks,
    Raoul
     
  38. faqilah92

    faqilah92

    Joined:
    Apr 7, 2017
    Posts:
    7
    hello..i want to know
    what the asset package the features is fully for make simulation for train?
     
  39. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hello faqilah92,

    Do you mean train physics? That is currently not part of the package.

    EasyRoads3D primarily is a procedural geometry creation tool optimized for road network creation. And also very useful for creating other objects like fences, walls, train rails, etc.

    More train rails prefabs will follow later and perhaps also train physics if there is a general demand for that but no guarantees for this at this stage :)

    Thanks,
    Raoul
     
    red2blue likes this.
  40. nikolai-niedermeier

    nikolai-niedermeier

    Joined:
    Mar 30, 2017
    Posts:
    6
    Hi Raoul

    Firstly, I would like to say thanks for adding the I Connector and the "Distribute Y Evenly" function. They both are extremely helpful and like you said especially in hilly areas.

    I have a couple of problems though:

    • I have built my road but then at the sides of the roads the terrains are very uneven (See the attached screenshot). When I use the Smoothen Surrounding Area button in build mode, I get an "Array index is out of range" error (see below). My surrounding area is set to 5 and as my heightmap resolution is quite high (513), due to my road being in quite a hilly area and requiring a high resolution to avoid z-fighting with the terrains.
    Unsmooth.JPG

    Code (CSharp):
    1. IndexOutOfRangeException: Array index is out of range.
    2. EasyRoads3Dv3.ODQQQQDDOQ.TerrainSmooth (UnityEngine.Terrain terrain, EasyRoads3Dv3.ERModularRoad road, Single size, Int32 type, System.Int32& smoothStep)
    3. EasyRoads3Dv3Editor.OOQCQDQQDQ.OnInspectorGUI ()
    4. UnityEditor.InspectorWindow.DrawEditor (UnityEditor.Editor editor, Int32 editorIndex, Boolean rebuildOptimizedGUIBlock, System.Boolean& showImportedObjectBarNext, UnityEngine.Rect& importedObjectBarRect) (at C:/buildslave/unity/build/Editor/Mono/Inspector/InspectorWindow.cs:1227)
    5. UnityEditor.DockArea:OnGUI()
    • Every time I leave play mode my lightmaps are being generated again. I have auto switched on in the lighting panel and have tried to turn off the option of building lightmap UVs for the roads in edit mode. Nothing seems to help. I am not sure if this is an EasyRoads problem.
    • I would like to know if you have any advice regarding variable resolution heightmaps? As you can see from my screenshot, I need quite a high heightmap resolution, due to my road being in a hilly area and it being quite long (sliced into sections with the I Connector though). Would it be possible to implement a system that increases the heightmap resolution (i.e. 4096) only close to the road and then at say 10m away decrease the resolution to for example 256. This should be a lot more performant than having a couple of big terrains all at 4096 resolution. Are there any other terrain assets that can do something like this?
    For you information, I am using Easy Roads 3D Pro v3 beta 8.5 and Unity 5.5.3f1.
     
  41. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi Nikolai,

    Glad to hear the new I Connector is useful for you. Indeed "Distribute Y Evenly" is a big time saver in hilly areas.

    The surrounding smoothing option will only have results if the surrounding area exceeds multiple terrain points. The surroundig value in your scene is 5 and the heightmap resolution 513, what is your current terrain size? That doesn't mean otherwise errors are raised, I will check if I can recreate that. Also, can tweak the surrounding values per marker.

    The road network constantly updates meshes. Therefore it is recommended to switch off "Auto" in the lighting panel whilst creating the road network. I don't think there are updates though after leaving play mode. Does that always happen or with the road network selected in the hierarchy? I will look into this as well.

    Variable terrain heightmap resolutions like you described are unfortunately not possible. If you only need detail near the roads you could consider using a mesh terrain with optimized LOD tiles. Anoher option would be using side objects for terrain mesh overlays. This will allow detail near the road. The mountain road screenshots on the first page are an example of this. The same shader can be used as used for the images just above your post. The terrain surface meshes will blend with the terrain. I am not a shader expert but I managed to get something together last week for additional detail. These shaders will be part of the new upcoming v3 demo project.

    Thanks,
    Raoul
     
  42. nikolai-niedermeier

    nikolai-niedermeier

    Joined:
    Mar 30, 2017
    Posts:
    6
    Sorry I forgot to mention that earlier, my terrains are all 855x855 with a heightmap resolution of 513. I believe that this is fine because I don't see that the terrains are sticking through the roads. I seem to have fixed the jagged edges as seen in the first screenshot. I unbuilt the road and then selected the segment with the jagged edges and selected Copy Left/Right Surrounding to all markers". I then rebuilt the road. This fixed the jagged edges (see screenshot of the same segment). However after builing when I select "Smoothen Surrounding Area" I still get the same "array index out of range" error.

    Before
    Unsmooth.JPG

    After
    Smooth.JPG

    It always happens, even without the road network selected. I leave the road in built mode and continue doing other things, so the road network is not doing anything. Every time I leave play mode the lightmaps bake (I think it only bakes for the roads because it is quicker than when I baked the lightmaps initially).

    Thanks for the tips. I thought of this and have tried it before following your directions in a post a couple of pages back. I had problems with it though but I guess I will just have to play around with it more and let you know if I need any help.

    Thanks
     
  43. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    What you see at the bottom in the first image should not happen. This can be checked by looking at the surrounding surfaces. Do these white surfaces snap to the terrain on the outer parts?

    I was able to reproduce the error in a multi terrain setup and specific road settings. This will be fixed.

    I did a quick test, roads are not updated when leaving play mode. So that cannot be the problem. I will look deeper into this. Does the same thing happen in a duplicated scene with the road network removed? If, so, does the same happen in a duplicated project (very important :)) with the road network finalized?

    This is one of the more advanced procedures. The new demo project will include an example in a hilly area. Meanwhile, indeed please let me know if something is unclear / not working as expected.

    Thanks,
    Raoul
     
  44. nikolai-niedermeier

    nikolai-niedermeier

    Joined:
    Mar 30, 2017
    Posts:
    6
    They do now after I pressed "Copy Left/Right Surrounding to all markers", I see that they are a preview of how the edited terrain will look. As you can see in the second screen, all is fine now and I confirmed that the white surrounding area does now snap to the terrain. Thanks for the tip!

    Yes it does. I duplicated the scene and opened it. Immediately it starts to bake the lightmaps. I deleted the road network and waited for the bake to complete, go into play mode and leave again. Same story, lightmaps start the auto baking again.

    Yes it does. Duplicate project, open scene, finalize roads and let lightmaps auto bake. Play, leave and lightmaps bake again. I tried it a couple of times and always the same result. This time it is a lot quicker though, might be because I forgot my laptop on power saving mode and turned it off.

    I created a fresh Unity project with no assets. I made a simple terrain just so that I could see the shadows. I let the lightmaps auto bake and then entered and left play mode a couple of times. Every time the lightmaps auto bake after leaving play mode. Obviously it is quite quick because the scene is basically empty. So it seems to be a Unity thing. I've never worked with the auto mode on so I can't say if the previous versions were also like this. It is quite annoying because it slows everything down.

    Thanks, I am sure that then I will understand easily how it is done.

    Thanks for the help.
     
  45. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    The "Copy Left/Right Surrounding to all markers" updates the surrounding positions. The same should happen, for example, when a road marker has changed position.

    In that case, I am not sure what could cause that. We always have "Auto" off for lighting during development because indeed it is slowing down everything. But glad to hear this it is not related to EasyRoads3D :)

    Thanks,
    Raoul
     
  46. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Beta 8.5.1 is now available for download from our website

    This is an update with primarily small bug fixes and some improvements.

    One of the improvements is that multiple node selection for both road shape nodes as side object shape nodes is now possible. It makes changing positions of several nodes in an identical way a little bit easier.

    swamp.jpg


    Furthermore scene view marker selection has been improved, this should no longer happen. And several requests have been implemented, like additional to the road angle display also the Grade of a road section and updating the mesh of scene instances of custom side objects after changes to the source mesh.

    The asset store update will be submitted tomorrow.

    As always, please backup your project first before importing the update :)

    Thanks,
    Raoul
     
    Last edited: Apr 24, 2017 at 9:00 PM
    600 likes this.
  47. em_develop

    em_develop

    Joined:
    Mar 6, 2017
    Posts:
    1
    Hi! Im using v3 beta, and after adding from gameobject->3d->EasyRoad3D-> new Road Network, im add some road blocks, then tap build terrain and now i want to access to position at distance, but how can i get ERRoad? On ERModularRoad "road" field is null.
     
  48. raoul

    raoul

    Joined:
    Jul 14, 2007
    Posts:
    2,647
    Hi em_develop,

    It is recommended to use the scripting API for that:

    Code (csharp):
    1.  
    2. // create reference to the existing road network
    3. ERRoadNetwork roadNetwork = new ERRoadNetwork();
    4.  
    5. ERRoad road = roadNetwork.GetRoadTypeByName("road name");
    6.  
    7. or
    8.  
    9. ERRoad road = roadNetwork.GetRoadByGameObject(GameObject object)
    10.  
    Thanks,
    Raoul