1. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice
  2. Unity 5.6 is now released.
    Dismiss Notice
  3. Check out all the fixes for 5.5 in patch releases 1 & 2.
    Dismiss Notice
  4. Get further faster with the Unity Plus Accelerator Pack, free for new Unity Plus subscribers for a limited time. Click here for more details.
    Dismiss Notice
  5. Learn how you'll soon be able to publish your games to China in four simple steps with Xiaomi. Sign up now for early access.
    Dismiss Notice

Video VideoPlayer not working on Android 7.0 on Moto G4

Discussion in 'Audio & Video' started by IvanQ, Apr 21, 2017 at 4:30 AM.

  1. IvanQ

    IvanQ

    Joined:
    Jul 30, 2015
    Posts:
    5
    While in the editor the video plays nice, I get a black screen when testing on my device. Checked the logcat and apparently there isn't any relevant message when I play the video. I am using the RenderTexture render mode. I've already tried the Camera render modes with same result. That's how I'm using the RenderTexture:

    rendetextureasset.PNG

    And my component:

    CompnentInspector.PNG
     
  2. IvanQ

    IvanQ

    Joined:
    Jul 30, 2015
    Posts:
    5
    Thing is, if I play a video with the Handheld class it plays perfectly. I'm using exactly the same video, with Handheld it plays, I've been using this way for a long time. But when I play with the Video player it is just a black screen. Sad. =/
     
  3. IvanQ

    IvanQ

    Joined:
    Jul 30, 2015
    Posts:
    5
    I've found that the VideoPlayer doesn't play if I set the Stripping Level. When I set to Disable the videos are playing normally but I get a crash when I call Stop()