1. We've introduced thread tags, search within a thread and similar thread search. Read more here.
    Dismiss Notice
  2. We've released our first Timeline Experimental Preview, our new tool for creating cutscenes and more! To check it out click here.
    Dismiss Notice
  3. All Unity Pro perpetual license customers: your special offer to subscribe is ready! Click here.
    Dismiss Notice
  4. Unity 5.5 is now released.
    Dismiss Notice
  5. Check out all the fixes for 5.5 in patch releases 1 & 2.
    Dismiss Notice
  6. Unity 5.6 beta is now available for download.
    Dismiss Notice
  7. Get prepared for the Tizen Mobile App Incentive Program! Read more about the upcoming program here.
    Dismiss Notice
  8. Enter the Microsoft Developer Challenge for a chance to win prizes. Read more about it here.
    Dismiss Notice

type == m_TransformInfo.transformType.. Mystery error?

Discussion in 'Editor & General Support' started by LeWyRaWr, Jul 29, 2012.

  1. LeWyRaWr

    LeWyRaWr

    Joined:
    Jul 6, 2012
    Messages:
    12
    Hey all,

    This has been posted before but no answer was given or resolved.

    I get an error of "type == m_TransformInfo.transformType" sometimes when I have an object attached to the bone of another gameobject and an animation is playing.

    For example, I have an assault rifle and there is a reflex sight model attached to the bone of the weapon, so that the reflex will inherit the parents animations.

    For some objects it doesn't occur, but some times it does and it looks like the scale is being distorted. I've attached two screenshots of the frame of the animation where the error comes in. I can't seem to find any reason as to why it would display an error like this. I've searched high and low for an answer but to not prevail

    Before:
    [​IMG]

    After:
    [​IMG]