1. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice
  2. We're looking for feedback on Unity Starter Kits! Let us know what you’d like.
    Dismiss Notice
  3. We’re giving 2017.1 beta testers a chance to win t-shirts and a Nintendo Switch. Read more on the blog.
    Dismiss Notice
  4. Unity 2017.1 beta is now available for download.
    Dismiss Notice
  5. Unity 5.6 is now released.
    Dismiss Notice
  6. Get further faster with the Unity Plus Accelerator Pack, free for new Unity Plus subscribers for a limited time. Click here for more details.
    Dismiss Notice
  7. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice
  8. Learn how you'll soon be able to publish your games to China in four simple steps with Xiaomi. Sign up now for early access.
    Dismiss Notice

Setting Compiler Options

Discussion in 'Scripting' started by DarkOmega, Feb 18, 2010.

  1. DarkOmega


    Feb 17, 2010
    Hello, I'm new to Unity, so maybe you guys could help me get some issues off of the ground. This is all C#.

    In order to use an existing library I have, I believe I need to modify compiler settings to accomplish two goals:

    -Enabling use of unsafe. At the points where my code uses 'unsafe,' I get the error "Unsafe code requires the 'unsafe' command line option to be specified."

    -Enabling use of System.Linq. Is there a way to do this, or is this not supported? "The type or namespace name 'Linq' does not exist in the namespace 'System'.

    I have tried modifying compile_any.pl, based on what I read elsewhere in the forums. In particular, in the region
    # Run the csharp compiler

    I added '-unsafe' and '-langversion:linq' to @base_args.

    This did nothing. I later got rid of the file compile_any.pl altogether (or rather, renamed it to compile_any2.pl) and it still doesnt make a difference, it compiles just as it used to.

    I have indeed modified and re-saved the files to make sure they are compiling, and it appears that they are. So maybe I'm modifying the wrong file?

    The one I have was found in, with my directory structure:
    C:\Program Files\Unity\Editor\Data\MonoCompiler.framework\compile_any.pl

    If it matters, Unity 2.6.1f3, Pro.

  2. Mat


    Dec 4, 2009
  3. pfiguero


    Jun 12, 2013
  4. Baste


    Jan 24, 2013
    six and a half year too late to the party, but I'm sure two posters that last visited the forum in 2011 appreciates the help.
  5. TaleOf4Gamers


    Nov 15, 2013
    Better late then never.