Hi Deozaan, Thank you for this nice plugin. Looking at your code I have a small recommendation for you which is related to the initialization of cInput, namely the creation of the gameobject which happens in the Init() method. For your cInput class (static singleton-like class) the concept of static initialization would perfectly apply. Doing this you could get you rid of all these _createObject() calls just to ensure that everything is initialized. Since I have to integrate cInput into our framework I would be happy to support you with this... xad PS: I would also be happy if you could move the menu GUI code into a separate class to keep things clean. Probably you already did this for the upcoming version.