1. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice
  2. Unity 5.6 is now released.
    Dismiss Notice
  3. Check out all the fixes for 5.5 in patch releases 1 & 2.
    Dismiss Notice
  4. Get further faster with the Unity Plus Accelerator Pack, free for new Unity Plus subscribers for a limited time. Click here for more details.
    Dismiss Notice
  5. Learn how you'll soon be able to publish your games to China in four simple steps with Xiaomi. Sign up now for early access.
    Dismiss Notice

High CPU Usage!

Discussion in 'Linux Editor' started by Scellow, Aug 26, 2015.

  1. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    100
    This seems to be fixed on 5.6.0b1 :)
     
    kmare likes this.
  2. u_rs

    u_rs

    Joined:
    Jan 5, 2016
    Posts:
    63
    What weed you are smoking there ? ) It's NOT fixed, I tried.
     
  3. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    100
    @u_rs it's good weed

    @_jp maybe that's because I added -no-throttle-updates to the launch script, try editing /usr/bin/unity-editor and removing that parameter.
     
    Last edited: Dec 26, 2016
    fumangy likes this.
  4. _jp

    _jp

    Joined:
    Feb 10, 2015
    Posts:
    4
    spacepluk likes this.
  5. longren15949

    longren15949

    Joined:
    Apr 21, 2017
    Posts:
    5
    I got the same question on debian 8 with unity5.4.And the cpu usage over 100%.I still didn't fix it.
     
  6. longren15949

    longren15949

    Joined:
    Apr 21, 2017
    Posts:
    5
    How did you do that?I can't fin unity-editor at /user/bin.
     
  7. longren15949

    longren15949

    Joined:
    Apr 21, 2017
    Posts:
    5
    How to add the arguments -no-throttle-updates to the launch script?
     
  8. longren15949

    longren15949

    Joined:
    Apr 21, 2017
    Posts:
    5
    I am on Ubuntu 16.04, Unity 5.6
     
  9. u_rs

    u_rs

    Joined:
    Jan 5, 2016
    Posts:
    63
    I had that problem several posts above. With 5.5.3f1 (latest build) there is no CPU problem, I use 16.04 too. Why are you using 5.6, try the latest build. But there the other problem - Unity shuts down occasionally.
     
  10. longren15949

    longren15949

    Joined:
    Apr 21, 2017
    Posts:
    5
    I will try 5.5.3f1,thanks. I used 5.4 before,but it has the cpu problem. Someone said that the problem was fixed by unity5.6,so I download it. But I found it didn't help.Since the moring,I found that I can't launched anymore cause it will shut down by itself. I am confused by that.
     
  11. kmare

    kmare

    Joined:
    Jan 30, 2016
    Posts:
    28
    Just to clarify, unity 5.5.3f1 is indeed the latest build from of the 5.5 series. The 5.6.0f3 is the latest from the 5.6 series.