1. We're looking for feedback on Unity Starter Kits! Let us know what you’d like.
    Dismiss Notice
  2. Unity 2017.2 beta is now available for download.
    Dismiss Notice
  3. Unity 2017.1 is now released.
    Dismiss Notice
  4. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  5. Reddit AMA with Adam Myhill on Cinemachine, Thurs July 27 - 10AM PT. More info.
    Dismiss Notice
  6. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice
  7. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice

GetComponent(TrailRenderer).active ??? HELP :)

Discussion in 'Scripting' started by AgentChaos, Apr 13, 2012.

  1. AgentChaos

    AgentChaos

    Joined:
    Jan 10, 2011
    Posts:
    33
    this.GetComponent(TrailRenderer).active=false;

    why its deactivate my player and not the trail ??
    Thanks..:D
     
  2. diablo

    diablo

    Joined:
    Jan 3, 2011
    Posts:
    736
    Post some more of your code so we can get a better picture.
     
  3. Tseng

    Tseng

    Joined:
    Nov 29, 2010
    Posts:
    1,217
    Because you are ignoring compiler warnings.

    Component.active is deprecated and should not be used with COMPONENTS. Component.active is/was a shortcut for "GameObject.active", hence if you have read the documentation (or MonoDevelop tooltips or the compiler warnings) you would know that this property is not listed in the docs and deprecated in MonoDevelop.

    Only "Component.enable" is documented and the only one which should be used, but that's something that the warning tells you too iirc.
     
  4. AgentChaos

    AgentChaos

    Joined:
    Jan 10, 2011
    Posts:
    33
    Thanks. So I can activate..How can I deactivate the trail?
     
  5. Tseng

    Tseng

    Joined:
    Nov 29, 2010
    Posts:
    1,217
    Did you even read what I said? Component.active should not be used with Components, only with GameObjects. It's deprecated.

    To enable/disable a component, you must use Component.enable (set it to true to enable and false to disable)