Search Unity

  1. We're looking for feedback on Unity Starter Kits! Let us know what you’d like.
    Dismiss Notice
  2. Unity 2017.2 beta is now available for download.
    Dismiss Notice
  3. Unity 2017.1 is now released.
    Dismiss Notice
  4. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  5. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice
  6. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice

Cannot get Unity monodevelop to compile. Error: {E097FAD1-6243-4DAD-9C02-E9B9EFC3FFC1}'

Discussion in '2D' started by Moonsunier, Aug 12, 2017 at 8:30 PM.

  1. Moonsunier

    Moonsunier

    Joined:
    Saturday
    Posts:
    1
    So I was trying to follow a tutorial, and there have been 2 problems. Using monodevelop gave me that error message - I tried dealing with this through the other questions, but nothing has worked so far. Then I tried Visual Studio, but when I do this:
    using UnityEngine;
    public class NumberWizard : MonoBehaviour
    {
    // Use this for initialization
    void Start()
    {
    //Like Java, this is literally 'printing' something to the console//
    print("Welcome to Number Wizard");
    print("Hope you enjoy the game!");
    //Creating a variable. int = integer (countable variables)//
    #pragma warning disable CS0219 // Variable is assigned but its value is never used
    int max = 1000;
    int min = 1;
    #pragma warning restore CS0219 // Variable is assigned but its value is never used
    print("The highest number that you can pick is" + max);
    }
    // Update is called once per frame
    void Update(){
    }
    }
    There is an error as apparently 'type numberwizard is already defined' (basically..it differs when I hover on 'Update', 'Start' and 'NumberWizard'. Also, the variables made me do that #pragma; these are all errors monodevelop does not have.

    Is there any way to resolve these issues?