1. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice
  2. We're looking for feedback on Unity Starter Kits! Let us know what you’d like.
    Dismiss Notice
  3. We’re giving 2017.1 beta testers a chance to win t-shirts and a Nintendo Switch. Read more on the blog.
    Dismiss Notice
  4. We want to know how you learned Unity! Help us by taking this quick survey and have a chance at a $25 gift card
    Dismiss Notice
  5. Are you an artist or level designer going to Unite Europe? Join our roundtables there to discuss artist features.
    Dismiss Notice
  6. Unity 5.6 is now released.
    Dismiss Notice
  7. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice

Black screen hiding new Unity 5.5 splash screen

Discussion in 'Android' started by icebear007, Dec 9, 2016.

  1. FMTharak

    FMTharak

    Joined:
    Mar 24, 2017
    Posts:
    2
    Just created a new project, save scene, build and run. Same thing happens before unity's logo.
     
  2. Mark-Sweeney

    Mark-Sweeney

    Joined:
    Feb 21, 2010
    Posts:
    161
    I'm getting the same thing on 5.6.1f1 for iOS. Even with iPhone Launch screen set to None, it was still showing Legacy Launch Images before the new launch screen for Personal Edition. Removing the images from Legacy Launch Images just gives you a blank screen before the Personal Edition launch screen
     
  3. raydekk

    raydekk

    Joined:
    Mar 14, 2013
    Posts:
    50
    I'm getting a gray screen before my splash screen on iOS, then the spash screen is shown. On Unity Plus 5.6.1p3 now.

    Settings: Light on Dark
    Animation: Custom
    Logo Zoom: 0
    Background Zoom: 0.3
    Logo Duration: 4
    Overlay opacity: 0.2

    One logo, one background image and one alternate portrait image. Though removing the portrait image didn't do anything.
    Launch screens are set to None.
     
  4. ofusion

    ofusion

    Joined:
    Dec 5, 2013
    Posts:
    19
    I find the same problem int my project.
     
  5. karl_jones

    karl_jones

    Unity Technologies

    Joined:
    May 5, 2015
    Posts:
    2,288
    Did this problem occur in 5.5? If you remove the background image and change the background color does the initial color change or is it always gray?
     
  6. Mark-Sweeney

    Mark-Sweeney

    Joined:
    Feb 21, 2010
    Posts:
    161
    I don't know if it happened in 5.5
    Removing the background image, deleting the app off the iPhone and reinstalling it removes the old launch image, but you get the grey blank screen first. I assume it's the default launch images (as shown below from Xcode) showing up anyway?

    http://mark-sweeney.com/Unity3d/LaunchImages.png

    If I delete the launch images in Xcode, I get a stretched out version of the app icon showing up instead of the launch images.