1. We're looking for feedback on Unity Starter Kits! Let us know what you’d like.
    Dismiss Notice
  2. Unity 2017.2 beta is now available for download.
    Dismiss Notice
  3. Unity 2017.1 is now released.
    Dismiss Notice
  4. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  5. Reddit AMA with Adam Myhill on Cinemachine, Thurs July 27 - 10AM PT. More info.
    Dismiss Notice
  6. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice
  7. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice

Animations that used to work are now messed up

Discussion in 'Animation' started by radiantboy, Apr 14, 2017.

  1. radiantboy

    radiantboy

    Joined:
    Nov 21, 2012
    Posts:
    539
    I have noticed that a lot of animations that were working fine in Unity 5 about 6 months ago, are now not correct in the latest Unity. I have quite a few animations like this, since they have gone bad the character leans forward 45 degrees and one of their arms stick out twisted behind their back.

    The animation that I just noticed this on was working fine (comes from the republic assets on the store - StandingIdleLooking) and is set up with rig-> humanoid. What could cause an animation that was perfect to suddenly be like this ? I have noticed a number of my mixamo fuse and poser animations also do this now too.
     
  2. RobCigna

    RobCigna

    Joined:
    Apr 24, 2013
    Posts:
    1
    Try reimporting the avatar those animations are using.
     
    radiantboy likes this.
  3. radiantboy

    radiantboy

    Joined:
    Nov 21, 2012
    Posts:
    539
    thanks man, good idea, will try it!!!
     
  4. radiantboy

    radiantboy

    Joined:
    Nov 21, 2012
    Posts:
    539
    Deleted library folder and reimported, they work now!.. Thanks dude.
     
  5. jeffthoms321

    jeffthoms321

    Joined:
    Apr 26, 2017
    Posts:
    15
    radiantboy likes this.