1. We're looking for feedback on Unity Starter Kits! Let us know what you’d like.
    Dismiss Notice
  2. Unity 2017.2 beta is now available for download.
    Dismiss Notice
  3. Unity 2017.1 is now released.
    Dismiss Notice
  4. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  5. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice
  6. Help us improve the editor usability and artist workflows. Join our discussion to provide your feedback.
    Dismiss Notice

Animation only running once

Discussion in 'Animation' started by Reloque, Jul 17, 2017.

  1. Reloque

    Reloque

    Joined:
    Apr 28, 2015
    Posts:
    34
    I am certain I am just missing something, but since 2 days, my idle animations only run once and never return. I've made a new empty project, put in a simple animation and it just runs once, and then stays forever in the completed position, like in the pictures;

    Screen Shot 2017-07-17 at 16.48.14.png Screen Shot 2017-07-17 at 16.48.07.png


    There is nothing else going on, just a simple sprite changing from one to another, nothing else. In the editor it loops, but in the game, it just runs once. And never again. Most answers I googled don't apply or are about stopping loops instead of running them. I am using 2017.1.0f3 and feel positively stumped.
     
  2. DouglasPotesta

    DouglasPotesta

    Joined:
    Nov 6, 2014
    Posts:
    14
    Go to the animation clip file.
    upload_2017-7-17_21-43-56.png

    Then click the check box next to loop time so there is a checkmark.

    upload_2017-7-17_21-45-16.png

    if you are using a model animation it is the same thing just scroll down to loop time in the animation window of the model import.
     
    theANMATOR2b likes this.
  3. Reloque

    Reloque

    Joined:
    Apr 28, 2015
    Posts:
    34
    See, I knew I was too tired/oblivious to code. Thank you very much, I'll be in the corner turning some shade of red.