1. We've introduced thread tags, search within a thread and similar thread search. Read more here.
    Dismiss Notice
  2. Learn how you'll soon be able to publish your games to China in four simple steps with Xiaomi. Sign up now for early access.
    Dismiss Notice
  3. Get further faster with the Unity Plus Accelerator Pack, free for new Unity Plus subscribers for a limited time. Click here for more details.
    Dismiss Notice
  4. We've released our first Timeline Experimental Preview, our new tool for creating cutscenes and more! To check it out click here.
    Dismiss Notice
  5. Unity 5.5 is now released.
    Dismiss Notice
  6. Check out all the fixes for 5.5 in patch releases 1 & 2.
    Dismiss Notice
  7. Unity 5.6 beta is now available for download.
    Dismiss Notice

A couple of errors in 5.5b10 !

Discussion in '5.5 Beta' started by Vagabond_, Nov 2, 2016.

  1. Vagabond_

    Vagabond_

    Joined:
    Aug 26, 2014
    Posts:
    246
    This if for the devs to be aware of these errors. Just opened a project in b10 and i get these errors. You might want to check:

    1. Failed to determine 'C:/Program Files/Unity 5.5.0b10/Editor/Data/UnityExtensions/Unity/VR/WindowsStoreApps/uap_arm/AudioPluginMsHRTF.dll' machine type, the value vas 0x01c4

    2. Failed to load 'C:/Program Files/Unity 5.5.0b10/Editor/Data/UnityExtensions/Unity/VR/WindowsStoreApps/uap_arm/AudioPluginMsHRTF.dll', expected x64 architecture, but was Unknown architecture. You must recompile your plugin for x64 architecture.
     
    ksam2 likes this.
  2. Hyp-X

    Hyp-X

    Joined:
    Jun 24, 2015
    Posts:
    65
    I get these errors too.
    Windows 10 x64
    Windows store target support is not installed for Unity
     
  3. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    251
    Hi,
    Thanks for reporting those. Could you please file bug reports for them?
     
  4. Spy-Shifty

    Spy-Shifty

    Joined:
    May 5, 2011
    Posts:
    68
    I want to share a bug too!

    All warnings in the project are interpreted as errors!

    Even obsolete-script warnings!
     
  5. Gizmoi

    Gizmoi

    Joined:
    Jan 9, 2013
    Posts:
    260
    Last edited: Nov 3, 2016
    ksam2 likes this.
  6. quitebuttery

    quitebuttery

    Joined:
    Mar 12, 2011
    Posts:
    262
    Yep I have this same issue, installing metro support does not fix it.
     
  7. Gizmoi

    Gizmoi

    Joined:
    Jan 9, 2013
    Posts:
    260
    Bug reported. Waiting on the confirmation email with the bug number.

    EDIT: Bug #848980
     
  8. ksam2

    ksam2

    Joined:
    Apr 28, 2012
    Posts:
    833
    Same issue.
     
  9. Gizmoi

    Gizmoi

    Joined:
    Jan 9, 2013
    Posts:
    260
    Got a reply from QA Team:
    "Thank you for the bug report. This is a known issues and it is already fixed. The fix will be available in upcoming betas."
    Hopefully the next beta :)
     
    ksam2 and MrEsquire like this.
  10. augheyj

    augheyj

    Joined:
    Oct 24, 2016
    Posts:
    1
    So what do we do in the mean time? 5.5.0b10 is unusable and there is no b9 installer to go back to the previous version.
     
  11. Gizmoi

    Gizmoi

    Joined:
    Jan 9, 2013
    Posts:
    260
    This bug in no way impacted on performance or usability of the Editor. b10 is completely useable these errors are more of an annoyance and doesn't seem to stop anything working.
     
  12. TruffelsAndOranges

    TruffelsAndOranges

    Joined:
    Nov 9, 2014
    Posts:
    90
    Same problem here. Everything working, but these errors look really ugly.
     
  13. hierro__

    hierro__

    Joined:
    Sep 22, 2014
    Posts:
    34
    Well, the project cant be saved as B10 and always give error on unity opening, this is creating problems to team versioning.
     
  14. Tyua

    Tyua

    Joined:
    Sep 6, 2012
    Posts:
    14
  15. TruffelsAndOranges

    TruffelsAndOranges

    Joined:
    Nov 9, 2014
    Posts:
    90
    Beta 5.5.0b11 gives the same errors. Even after deleting library and rebuilding:
    Code (CSharp):
    1. Failed to determine 'C:/Program Files/Unity 5.5.0b11/Editor/Data/UnityExtensions/Unity/VR/install_with_editor/WindowsStoreApps/uap_arm/AudioPluginMsHRTF.dll' machine type, the value vas 0x01c4
    This error also appeared in 5.5.0b11:
    Code (CSharp):
    1. Assertion failed on expression: 'm_CurrentEntriesPtr != NULL && m_IsGettingEntries'
     
    ksam2 likes this.
  16. quitebuttery

    quitebuttery

    Joined:
    Mar 12, 2011
    Posts:
    262
    Yep, not fixed in 5.5.0b11
     
    jewelsjacobs likes this.
  17. Ed-unity

    Ed-unity

    Unity Technologies

    Joined:
    Nov 18, 2013
    Posts:
    253
    This should be fixed in the next 5.5 release. It shouldn't impede your development in b11, but it will show up any time you restart or re-import all. If you don't want to see the error, delete the file at the location shown in the error. It's .meta file was corrupted.

    As a side note, if you don't have Visual Studio installed on your machine, you will also see a similar error trying to load the plugin. This is also a know issue and will be fixed in the next version as well.
     
    Gizmoi likes this.
  18. Hyp-X

    Hyp-X

    Joined:
    Jun 24, 2015
    Posts:
    65
    Still not fixed in 5.5.0f1 (RC1)
     
    MrEsquire likes this.
  19. Gizmoi

    Gizmoi

    Joined:
    Jan 9, 2013
    Posts:
    260
    Really? it's fixed for me.
    It popped up the first time, but after that it's gone.
    Though I do have some timestamp out of sync errors which may or may not be releated.
     
  20. Hyp-X

    Hyp-X

    Joined:
    Jun 24, 2015
    Posts:
    65
    Ok, looks like it's first time only.
    Probably something the previous version left behind