Unity Webplayer doesn't work

Discussion in 'Unity Support' started by akshayk29, Mar 19, 2013.

  1. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
    OS : Windows XP SP3
    Processor : AMD Sempron (SSE2 support)
    RAM : 991 MB
    Unity Plugin Version : 4.1.0f4
    Unity Engine Version : 3.5.7f6

    Hello.
    Whenever I try to open a Unity game from any of the browsers, I get the following message :
    "Error Launching Unity Player"
    Error Details : Failed to start Unity Player.
    Any help would be appreciated.
    Screenshot attached.


    Thanks,
    akshayk29

    Attached Files:

  2. UnityCoder

    UnityCoder

    Member

    Joined:
    Dec 8, 2011
    Messages:
    527
    Before this is it working perfectly on your system?
  3. CreativeChris

    CreativeChris

    Unity Technologies

    Joined:
    Jun 7, 2010
    Messages:
    350
    Can you attach the WebPlayer log file?

    Thanks,
    Chris
  4. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
    It is not working since a few days.
  5. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
    Can you tell me how to?
  6. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
    Sorry for being silly. :)
    I found out where is the log file.
    Attaching it.


    Thanks for the quick reply anyways.

    Attached Files:

  7. CreativeChris

    CreativeChris

    Unity Technologies

    Joined:
    Jun 7, 2010
    Messages:
    350
  8. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
    Nope. English-US.
  9. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
    Any help?


    EDIT : It seems that the problem happens only on some games that I try. Others work fine.
    Any information about this behaviour would be appreciated.
    Last edited: Mar 22, 2013
  10. UnityCoder

    UnityCoder

    Member

    Joined:
    Dec 8, 2011
    Messages:
    527
    If its working before then do onething make one webplayer from your system and open it, if its working, then its your harware problem. Content in that weblayer which you trying to open may be not supported by your hardware.
  11. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
  12. UnityCoder

    UnityCoder

    Member

    Joined:
    Dec 8, 2011
    Messages:
    527
    Hi Akshay,


    Link provided by you works fine on my system. I am sure that your hardware not support shader used in that game. According your configuration i think your system is very old.
  13. Aurore

    Aurore

    Community Rambo Unity Technologies

    Joined:
    Aug 1, 2012
    Messages:
    1,706
  14. Annihlator

    Annihlator

    Member

    Joined:
    Oct 15, 2012
    Messages:
    377
    The game works fine here too, was this exact game working on your computer before?
    Potentially an update in the game caused it otherwise :/
  15. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
    Should I download the full Unity or just update the Webplayer?
  16. CreativeChris

    CreativeChris

    Unity Technologies

    Joined:
    Jun 7, 2010
    Messages:
    350
  17. akshayk29

    akshayk29

    New Member

    Joined:
    Mar 19, 2013
    Messages:
    9
    Didn't work. Will try again in the weekends.
  18. JamesArndt

    JamesArndt

    Member

    Joined:
    Dec 1, 2009
    Messages:
    1,583
    I'm getting this error now too, never historically have. I'm using Unity Version: 4.2.0.76773....funny thing is all my Unity 3.57 authored content plays fine with the webplayer in the browser. So the webplayer is working in my browser. I get "unity error launching unity player" when I try "Build and Run" from the editor. I'm wondering if it has to do with some mismatch with my editor vs. the plugin version. Unity web site is telling me I'm using 3.5.7, but I'm using 4.2. Any insights or help?
  19. jonas echterhoff

    jonas echterhoff

    Unity Technologies

    Joined:
    Aug 18, 2005
    Messages:
    486
    The Unity web player is actually using different runtime versions based on content version. See this blog post for an explaination. So it seems that the 3.5.7 runtime works on your machine, 4.2 does not. This may be a bug, or it may be because we have actually dropped support for your machine, if you have very old hardware (we now require SSE2, IIRC).
  20. JamesArndt

    JamesArndt

    Member

    Joined:
    Dec 1, 2009
    Messages:
    1,583
    Jonas - Thank you for responding so quickly. I have a Pentium Dual Core that tells me supports SSE2, not sure what IIRC is though? Cannot find any info on it? I did follow through to that Unity page with the blog post...followed through to http://cdn2.unity3d.com/setup-3.x/ and when I right click on the web player I click on "Setup" but no options appear at all to select Stable - Release? It just reloads.

    My Processor supports: MMX, SSE, SSE2, SSE3, EM64T

    Now I do have some services in Windows XP turned off, wondering if there are any critical Windows XP services needed for webplayer to work? I don't think this is the issue though as the 3.57 authored webplayers run fine in the browser.
    Last edited: Aug 8, 2013
  21. jonas echterhoff

    jonas echterhoff

    Unity Technologies

    Joined:
    Aug 18, 2005
    Messages:
    486
    your computer should be supported fine - IIRC is just an abbreviation for "if i recall correctly" :)

    So, in that case, I don't know what the problem is. You should probably file a bug and work with our QA team to see if they can find out what is breaking it on your setup.
  22. JamesArndt

    JamesArndt

    Member

    Joined:
    Dec 1, 2009
    Messages:
    1,583
  23. JamesArndt

    JamesArndt

    Member

    Joined:
    Dec 1, 2009
    Messages:
    1,583
    Bug report sent with the following description:

    "I use the Build and Run menu to build a Unity 4.2.04f webplayer. It builds and runs it, but in the browser it gives me an "Error Launching Unity Player Error". I click on the Details tab and it says "Failed to Start Unity Player". I am using Windows XP SP3 and I do have a processor that supports SSE2. This happens in both the latest Chrome and Firefox browsers. My Unity 3.57 authored webplayers ran just fine and they still do. I can play all of them back on the same PC that is having the issue playing back all 4.2 authored webplayers."
  24. JamesArndt

    JamesArndt

    Member

    Joined:
    Dec 1, 2009
    Messages:
    1,583
    I've had zero response on my bug report so far. I sent this one week ago.
  25. JamesArndt

    JamesArndt

    Member

    Joined:
    Dec 1, 2009
    Messages:
    1,583
    Still nothing? What gives?
  26. Skylabh

    Skylabh

    Member

    Joined:
    Jun 26, 2011
    Messages:
    17