1. Before updating to Windows 10 you may need to return your Pro license. More information here

Unity Web Player doesn't work

Discussion in 'Editor & General Support' started by octabrain, Dec 6, 2012.

  1. octabrain

    octabrain

    Joined:
    Dec 6, 2012
    Messages:
    2
    Hi,
    I'm trying to install Unity Web Player, but it just doesn't work. The installation process seems to work just fine, but on the unity start page it keeps telling me:
    Version of your web player
    Unity Plugin version:not installed
    Unity Engine version:not installed
    I uninstalled it a couple of times, after closing all browsers. Restarted, installed with all browsers closed. The version I used to install is the one found on the home page: http://webplayer.unity3d.com/download_webplayer-3.x/UnityWebPlayer.exe
    I'm running Win7 64bit.
    Let me know if you need any further information.
    Cheers
     
  2. Loius

    Loius

    Joined:
    Aug 16, 2012
    Messages:
    540
    Current web player doesn't work on Chrome. Use FireFox or Internet Exploder; I believe Opera may also currently be working but I know FF is.

    I no longer know whether to shudder more for Firefox or Exploder.
     
  3. octabrain

    octabrain

    Joined:
    Dec 6, 2012
    Messages:
    2
    Thanks for your help. Yes, I was using Chrome. Tried it in FF and all was fine.
     
  4. CreativeChris

    CreativeChris

    Unity Technologies

    Joined:
    Jun 7, 2010
    Messages:
    354
    Hey guys,

    Unity WebPlayer is supported on Chrome for Both Windows and Mac.

    What version of Chrome are you running?

    Thanks,
    Chris
     
  5. Graham Dunnett

    Graham Dunnett

    Unity Technologies

    Joined:
    Jun 2, 2009
    Messages:
    3,957
  6. Loius

    Loius

    Joined:
    Aug 16, 2012
    Messages:
    540
    I'm on Chrome Version 23.0.1271.95 m (oh god, I'm glad they hide that number -_-), with NotScript (all scripts enabled). I've reinstalled the web player, I've reinstalled chrome, all scripts and plugins are allowed. Chrome cannot detect my web player.
     
  7. Loius

    Loius

    Joined:
    Aug 16, 2012
    Messages:
    540
    I was able to get mine to work on Chrome:

    Uninstall Chrome (using the add/remove programs feature), and uninstall Unity Web Player.
    Install Unity Web Player.
    Install latest stable Chrome version (I used the local installer, as the over-the-net one did not work for me).
    Uninstall Web Player.
    Install Web Player.

    I'm hoping some of those steps were unnecessary. :)
     
  8. p3droxd

    p3droxd

    Joined:
    Sep 23, 2014
    Messages:
    1
    does not work on explorer it download good and everything but when you go on a game it asks to download the plugin when I already have it
     
    Infinity2015 likes this.
  9. Luvsonic

    Luvsonic

    Joined:
    Nov 28, 2014
    Messages:
    1
    i have that same problem what p3roxd said
     
  10. Infinity2015

    Infinity2015

    Joined:
    Dec 1, 2014
    Messages:
    3
    I have that problem too! I download it, I refresh the page to play the game, and it tells me I need to download the Unity.
     
  11. Infinity2015

    Infinity2015

    Joined:
    Dec 1, 2014
    Messages:
    3
    I am using Internet Explorer. I downloaded it and when I want to play a game after I installed it, it tells me I need to do it again.
     
  12. Infinity2015

    Infinity2015

    Joined:
    Dec 1, 2014
    Messages:
    3
    Is it probably because I need to download a newer version?
     
  13. Aiursrage2k

    Aiursrage2k

    Joined:
    Nov 1, 2009
    Messages:
    3,391
    It doesnt work for me in chrome either only safaria seems to work
     
  14. kingfrito_5005

    kingfrito_5005

    Joined:
    Apr 28, 2015
    Messages:
    1
    I cant get it work in Chrome or IE, same problem as everybody else.


    EDIT: Got it to work in IE, dunno how, just tried it over and over till it worked. Still no luck with Chrome.

    EDIT: Finally fixed it. Chrome has several flags that need to be disabled for it to work. go to chrome://flags/#enable-npapi and disable 'Enable NPAPI' and 'Disable WebGL.' (both of these should be set to disable, the names make this very confusing but by disabiling enable NPAPI you are disabling npapi and by disabling disable webgl you are enabling webgl. I have no idea why that would not be the case by default, it certainly should be.
     
    Last edited: May 6, 2015
  15. kavyaislam94

    kavyaislam94

    Joined:
    Jun 4, 2015
    Messages:
    3
    I am also facing same problem,I am using mozila browser and download latest version of unity but facing the same problem can anyone give me solution about this please?