SuperHeroSquad and Unity Web Player not working in IE 9

Discussion in 'Unity Support' started by YossiDukes, Oct 31, 2011.

  1. YossiDukes

    YossiDukes

    New Member

    Joined:
    Oct 31, 2011
    Messages:
    2
    Hi,

    I am having problems with this web site (www.heroup.com) which uses the Unity Web Player foundation for it's online game.

    To clarify what the issue is: Their game does not start up at all. I just get a blank screen.

    After numerous emails with their technical support, they have sent me this:

    "We understand your frustration; however, please understand that Super Hero Squad Online will only play in browsers supported by the Unity Web Player as it is the core engine of the game. Currently they do not support any 64 bit browser.

    Additionally, we should also note that the DXDiag Report you sent does not provide us information about which browser you choose to play in, that is why we had you test the game again in Firefox.

    While we do recommend you play Super Hero Squad Online in Firefox (until you could determine what was causing the issue with Internet Explorer), we certainly do not required it.

    However, as the troubleshooting you did made it clear that the game connected and played without trouble in Firefox after having trouble with Internet Explorer, the issue does lie within the communication between Unity Web Player and Internet Explorer. As you have expressed a strong desire to only use Internet Explorer, you can follow up with Unity's Support Forums located HERE for more information on the issue."

    This all being said, I am not using a 64bit browser/windows/os etc, which they have indicated, but 32bit. I've been using IE 9 for some time without issues. I had to install Firefox to prove to them that there was no connectivity problems to their site. Now that this has been confirmed, they relinquished all responsibility and have thrown me over to you indicating this is a compatibility issue with the Unity Web Player and IE.

    So, just make sure there is nothing wonky going on, can you confirm of any connectivity problems using Unity Web Player and IE 9 ?

    Maybe you can try to run it on your workstation with IE 9 and see if you encounter the same issue.

    Looking forward to your quick reply,

    Yossi
  2. Dreamora

    Dreamora

    Member

    Joined:
    Apr 5, 2008
    Messages:
    26,586
    its incorrect anyway, since Unity 3.4 Unity had 64bit browser and standalone player support :)

    The problem with IE9 is a different one and thats its high security degree and how it enforces it on content if you don't invest hours configuring the security right ... and at worst even then the unity webplayer -> js in page -> unity webplayer communication fails
  3. YossiDukes

    YossiDukes

    New Member

    Joined:
    Oct 31, 2011
    Messages:
    2
    Thank you for your reply.

    Is it a configuration issue at the workstation running IE9 or at IIS rendering the HTML to the workstation?
    Or simply, is there something I can do on my workstation by changing some settings that will allow the game to run or is it a problem with the HTML that is being sent to my workstation?
    Last edited: Nov 4, 2011