1. Become a closed-alpha partner on the new Facebook games platform. Read more about it here.
  2. Enter the Samsung TIZEN App Challenge for a chance to win prizes. Read more about it here.

Profiler reports huge Overhead???

Discussion in 'Editor & General Support' started by zelk, Jan 24, 2010.

  1. zelk

    zelk

    Joined:
    Mar 13, 2009
    Messages:
    246
    When I run my game, I suddenly get a huge Overhead. See the screen shot. What does Overhead mean and how do I get rid of it. I tried running the Process Manager in Windows (or whatever it is called in English) and saw that no other applications but Unity was using the CPU so, what is Unity doing?

    /Ricky
     

    Attached Files:

  2. RElam

    RElam

    Joined:
    Nov 16, 2009
    Messages:
    374
    Appears to be processing exceptions. I've seen that happen (not sure it was exactly the same) when I'm causing a lot of errors/exceptions. I'd say look for exceptions or logs that are happening a great deal (turn off collapse).
     
  3. zelk

    zelk

    Joined:
    Mar 13, 2009
    Messages:
    246
    I restarted Unity and the overhead disapeared.
     
  4. StoneFish

    StoneFish

    Joined:
    Aug 26, 2012
    Messages:
    123
    I'm having this issue too. Have restarted unity and xcode and nothing changes. Also, there are no errors/exceptions appearing in Console.

    Could it be anything else? (e.g. would other programs i have open affect it?)
     
  5. foxter888

    foxter888

    Joined:
    May 3, 2010
    Messages:
    530
    sometimes that overhead shows up right when you start a unity game or lead the scene i meant,and yes sometimes it's the fact that its still trying to load some components. in my case normally see the garbage collectors spikes lol they always get on my nerves
     
  6. TheCheese

    TheCheese

    Joined:
    Nov 25, 2009
    Messages:
    82
    Having your scene window open creates a lot of overhead. While profiling your game, close / hide the scene window and that overhead should go away.
     
  7. MindLaunch

    MindLaunch

    Unity Technologies

    Joined:
    Jun 23, 2014
    Messages:
    3
    Hey,

    Overhead can usually be lowered considerably by setting targetframerate through script (also, keep in mind, that you should disable vsync).
     
  8. NomadKing

    NomadKing

    Joined:
    Feb 11, 2010
    Messages:
    1,462
    Such a bad necro... Aurore is gonna hunt you down!
     
  9. lmbarns

    lmbarns

    Joined:
    Jul 14, 2011
    Messages:
    1,439
    Why is it a bad necro? I'm getting it really badly in Unity 5 and not at the beginning of a scene........
    spike.jpg

    Using oculus rift so can't disable vsync.
     
    VipHaLongPro likes this.
  10. QI

    QI

    Joined:
    Oct 27, 2012
    Messages:
    195
    Well same problem here, got my game running very good in editor with 5% overhead, more than 1000fps. But on my iPad 2 it saids 95% overhead and less than 1fps..

    Anyone know how to deal with it?
     
    kobyle likes this.
  11. kobyle

    kobyle

    Joined:
    Feb 23, 2015
    Messages:
    51
    Any clue on that? same problem here
     
  12. QI

    QI

    Joined:
    Oct 27, 2012
    Messages:
    195
    I finally figured out it is because one of my shader is using to many bandwidth for iPad 2 to community with CPU, so disable the shader and it works smooth now.

    Overhead might indicating something the profiler not sure but cost times, so you need to think about everything when overhead to high.
     
  13. nopowerup

    nopowerup

    Joined:
    Aug 17, 2015
    Messages:
    1
    Hi QI,
    How can you figure out how much bandwidth a shader is using ?
    In my case, my game runs smoothly in every devices (iPhone 4S and up) except for iPad Mini 2. It has constant lag on iPad Mini 2 with very high and peak overhead :(