Fps Controller acceleration and deceleration

Discussion in 'Scripting' started by Flappish, Jul 24, 2012.

  1. Flappish

    Flappish

    New Member

    Joined:
    Jul 24, 2012
    Messages:
    4
    So basicly, I've tried everything I can to make my Fps Controller stop sliding around. By default it takes a little while to accelerate and a little time to come to a complete stop. This really annoys me because it makes the game feel really slippery and it's not pleasent to move around at all. I've checked out other threads, no anwsers there. I've tried increasing the max ground acceleration or whatever it's called, doesn't work. Tried changing some variables in the script, no diffirence. tried changing the acceleration curve, don't work. What should I do to get tighter controls?
  2. angrypenguin

    angrypenguin

    Member

    Joined:
    Dec 29, 2011
    Messages:
    4,576
    Are you using the default Horizontal and Vertical axis for input? If so, it's worth knowing that they're smoothed, so they're quite possibly the source of the problem. It could be that your FPSController is doing exactly what the input is telling it to do.
  3. Flappish

    Flappish

    New Member

    Joined:
    Jul 24, 2012
    Messages:
    4
    Went into Edit > Project Settings > Input and tried chaning some stuff on the Horizontal and Vertical axis, didn't seem to do anything. I really need help on this!
  4. Flappish

    Flappish

    New Member

    Joined:
    Jul 24, 2012
    Messages:
    4
    Please help I have no other options!!!