FlightTest: this device has not been given permission to install this build

Discussion in 'iOS Development' started by renman3000, Jun 13, 2012.

  1. renman3000

    renman3000

    Member

    Joined:
    Nov 7, 2011
    Messages:
    5,016
    Hi there,
    I am just getting started using Test Flight App and I have a question. One of my testers, whose name, device, are all confirmed, can not access the build. It tells him that he is not permitted to this build.

    I just did a check and went to the Permissions Page/Update Profile, there it asks for a Provisioning Profile. The relevant profile I have tho was rejected.

    Then I went on my own device to the link provided, but again, it tells me, as well, on the Install page, that this device has not been given permission to install this build.



    ???
  2. mrmadprofessor

    mrmadprofessor

    New Member

    Joined:
    May 22, 2012
    Messages:
    53
    Sounds like the device isn't added to the provisioning profile. You will still have to rebuild the game and add the new device with FlightTest (one of the bad things with iOS). Did you build it as adhoc?

    1: Send out invite
    2. Update the profile in Flight Test
    3. Rebuild the game with the new profile
    4. Upload and send out beta through Test Flight

    Please, correct me if I'm wrong. I'm not the one creating our builds at work.
  3. laserlars

    laserlars

    Member

    Joined:
    Nov 17, 2011
    Messages:
    251
    You have to add the device to your provisional profile on developer.apple.com
    After building and choosing "Save for Enterprise og Ad Hoc Deployment" -> Code signing identity, choose "Refresh code signing identity.." to update your profile.

    Reupload the .ipa to Testflight, add the new devices and you're ready to go.


    Edit: lol, it's actually TestFlight, not flighttest. My mind got tricked by the thread title.
    Last edited: Jun 13, 2012
  4. renman3000

    renman3000

    Member

    Joined:
    Nov 7, 2011
    Messages:
    5,016
    Thanks guys,
    I was hoping the problem was refreshing the profile like laserlars said, but that does not appear to be it.


    In the Test Flight Permissions Panel there are three sub titles:

    Update Provisioning Profile: here I uploaded my current provisioning profile.
    Anonymous Devices In the Provisioning Profile: I have two options: UDID (unchecked) and a Device ID (checked)
    Share This Build:
    Teammate Devices Not On This Profile:
    This holds all of my testers, including me. I have added each to the Provisioning Profile.





    Not sure what to do.





    Questions.
    I may have selected to use the SDK. Is this an issue?
    Also Export Missing Devices, in an option at the bottom of the page but that does not seem like a healthy choice.

    Obi Wan, are you out there?
  5. Tapgames

    Tapgames

    Member

    Joined:
    Dec 1, 2009
    Messages:
    161
    When you archive in Xcode make sure you export with the correct profile. Do not chose the developer profile but the Distribution Provisioning Profile. And include the devices in the profile. I deleted all my profiles and redo all of them with the new settings.

    Roy
  6. renman3000

    renman3000

    Member

    Joined:
    Nov 7, 2011
    Messages:
    5,016
    "When you archive in Xcode make sure you export with the correct profile. "
    - ok, but how do I insure the correct profile is selected? When I press Archive, it just archives. Without Archiving (when testing on device) it builds fine. So I assume the correct profile is slected. No?


    "Do not chose the developer profile but the Distribution Provisioning Profile."
    - ok, again, how do I insure this profile is selected?
  7. moonjump

    moonjump

    Member

    Joined:
    Apr 15, 2010
    Messages:
    1,584
    At the top of the left panel, chose the left icon to show you folder structure. It will probably be minimised to only show "Unity-iPhone". Click on "Unity-iPhone". To the right of this it will say "PROJECT" with "Unity-iPhone" underneath. Click on this "Unity-iPhone". Chose the "Build Settings" tab to the right of this. Scroll down to the "Code Signing" section and set the Profile in the "Release" section.
  8. renman3000

    renman3000

    Member

    Joined:
    Nov 7, 2011
    Messages:
    5,016

    Ok thank you.
    I am at the BuildSettings and Code Signing. Under Code Signing Identity the there a Release. It has a panel which I can set. Currently, it is set to "Don't Code Sign". I am a little hesitant to change anything.
    Last edited: Jun 13, 2012
  9. renman3000

    renman3000

    Member

    Joined:
    Nov 7, 2011
    Messages:
    5,016
    So neither setting Code Signing Identity to Release or Distribution worked.

    Thanks anyhow, I am waiting to hear back from Test Flight itself.

    The main issue as I perceive it is the permissions page where all of my teammates, including me are "Not On This Profile". And I did refresh the profile in XCode as suggested.



    :?
    Last edited: Jun 13, 2012
  10. yoDon

    yoDon

    Member

    Joined:
    Aug 29, 2008
    Messages:
    16
    Did you ever hear back from TestFlight on how to solve the problem? I'm seeing the same thing you described, everyone including me is listed as "Teammate Devices Not On This Profile."
  11. renman3000

    renman3000

    Member

    Joined:
    Nov 7, 2011
    Messages:
    5,016
    I can't recall, but it was fixed. I think the issue was just in the permissions page. I missed a setting or something, I think.
  12. liszto

    liszto

    Member

    Joined:
    Dec 22, 2011
    Messages:
    134
    HI,
    we got the same issue than you with our permissions page.
    All our device are ok except one which is in the provisioning profile used to build our app.

    It's really weird do you have some explanations ?

    All devices are on iOS 6.0 or earlier.

    The device which is not recognized is an iPhone5 but I don't think it's linked.
  13. renman3000

    renman3000

    Member

    Joined:
    Nov 7, 2011
    Messages:
    5,016
    Just make sure it is checked in the permissions page.