Fails to detect up-to-date andorid SDK, fails to update, endless loop

Discussion in 'Android Development' started by Abscissa, Oct 18, 2013.

  1. Abscissa

    Abscissa

    Member

    Joined:
    Oct 9, 2013
    Messages:
    3
    I tried to generate an Android build of a test project, and it gave me this error:

    "Android SDK is missing required platform api
    Minimum platform required is Android 4.0 (API level 14)"

    I then used the "Update SDK" button it gave, and it went into an infinite loop of "Updating Android SDK" and "Detecting installed platforms".

    I canceled it, downloaded the latest official Android SDK, and selected and installed all of the SDKs from 4.0/14 and up. But Unity is still fails to detect it, tries to update and goed back into the endless "Updating/Detecting/Updating/Detecting/etc" loop.
     
  2. Dovey

    Dovey

    Member

    Joined:
    Mar 5, 2014
    Messages:
    1
    I had exactly the same issue until 10 minutes ago so I might as well reply here in case it helps anyone else...

    I had an old version of the Android SDK installed from several years ago and it was in C:\Android\android-sdk

    Installing the most recent version of the Android SDK seems to have stuck it in C:\Program Files (x86)\Android\android-sdk

    However, Unity was still pointing at the old location so I changed it in Unity: Edit/Preferences.../External Tools/Android SDK Location

    Job done and it all works now :)

    Dovey