Unity Community


Page 11 of 19 FirstFirst ... 910111213 ... LastLast
Results 201 to 220 of 376

  1. Posts
    24
    hey guys,

    I started a page at my site where I will collect as many bugs between the book and Unity 3.5 as possible. I am only up to Chapter 4 and am trying to replicate stuff on my end before I add it to the page but if you want to send me known stuff to newbquest a t g mail d o t com (goofy spelling for spambots) or add them as comments on that page I'll be happy to add them.

    http://newbquest.com/bugs-and-fixes-...ith-unity-3-5/

    I know for us as learners our first impulse is to think its our fault so these kind of things can be especially challenging. I will also mention these in my on going chapter by chapter review of the book at my site. I'm up to Chapter 3 in the reviews.

    http://newbquest.com/category/beginn...review-series/

    Good luck everyone!
    One newb on an epic quest to learn to make video games
    Follow my journey at:
    http://www.newbquest.com
    tweet tweet: @newbquest


  2. Posts
    8
    Hi Sue

    I am at chapter 14, where I loaded the structures. I notice the cavern is not visible from above when the structure is lowered to ground level. Is this correct. ?. is there some mesh import problem ?. There are two structures prefabs available..one called structures prefab, and the other is simply called structures. Also page 729 doesn't show animations in the interactor..I got an index array error, before I added lid open, and closed animations.

    Best regards,

    Michael.


  3. Location
    Chicago
    Posts
    23
    An odd bug I've been getting. I finished the tutorials in the book..great book.
    But when it runs animations made in unity, on mesh objects, the collision animates but not the mesh. Is there anything I could have set odd that could cause this?


  4. Posts
    198
    hi Joe,

    I've never seen that- very weird
    does the mesh animate when the Animation view is open?
    is it a regular transform, or a skinned mesh/bone system?
    is it only one particular mesh? if so, which one?
    can you post a very tiny sample? maybe just a package of the animated object?

    hi Michael,
    the top of the cavern in my terrain was a little bit above ground, so it may be deactivated - otherwise if you bake lights you'll get a strange shadowed area
    also, you are looking into the cavern from the outside, so you won't see the outside faces- they are only drawn on the inside of the cavern

    the "Structures" object is the imported asset, the "Structures Prefab" is the version where I've fixed the Scale Factor and fixed all the materials on the imported objects, and then saved the new version as a prefab
    when I save the Structures Prefab as a UnityPackage, it also needs to save the original Structures imported asset because that's what has all of the mesh information and textures

    assuming 729 is the Stone Lid, good catch! Yes, that should be "stone chest close" in element 0 and "stone lid open" in element 1 for the Stone Chest Lid's Interactor script


  5. Location
    Charlotte, NC
    Posts
    5
    Hi Sue,
    First, thanks so much for writing this book, it's been great!
    Like a lot of others, I'm also starting with Unity 3.4 and have hit a wall in Chapter 10. I think you mentioned earlier in the thread that you'll be working on new downloadable assets of the finished code, is that right?
    I'm thinking about adopting this text for a course for art students interested in plunging into game creation, but since they'll all certainly be using 3.4 (or later whenever we get around to finalizing the class content), I'd want to hold off on adopting it until the downloadable resources are up-to-date...
    Okay, so long preamble for a short question:
    Any sense of an ETA for revisions for 3.4/3.5?
    Heather D. Freeman
    Assistant Professor of Digital Media
    Department of Art and Art History
    University of North Carolina at Charlotte
    http://www.EpicAnt.com


  6. Posts
    8
    Hi Sue,

    Have reached the end of chapter 15 finally. Have a couple of questions. The golden sleeve in the bowl is too high to be picked. Did I miss something here ? Do I have to construct a ramp in the corridor or is there access from somewhere at the rear perhaps. ?
    The cavern water, steli Topi, volume light, and spotlight have to be positioned well above the terrain to be in correct position inside the cavern in play mode. should the cavern be visible from above ..in my case it is not.
    My tree of life is very plain, and the leaves are rectangles. Doesn't seem to want to take any textures.he
    The trigger group for access down are intermittant.. the terrain drops but oftentimes I still can't go down the ramp to the temple lower level.

    Many thanks,

    Michael Harte.


  7. Posts
    198
    hi Heather,
    can you be more specific about "hit a wall"?

    the two biggest differences are:

    to use "internal" instead of "private" for the vars
    private prevents other scripts and outside applications from accessing the variables
    internal only prevents outside apps, so that's the one to use now

    and
    remove #pragma strict from the top of the scripts
    when authoring for mobile variables must by typed
    but Javascript was designed to figure out the type for you if you skip that part
    problem comes with arrays- regular javascript arrays apparently don't store the type for their contents- it's dynamically typed as needed- which is what gets flagged with #pragma strict
    Unity arrays must be typed, but there's lots of normal array things they can't do- that I've used in the book...

    if you are serious about using the book for a course, PM me and I'll make sure you get the scripts & stuff needed to move forward

    Sue


  8. Posts
    198
    hi Michael,

    golden sleeve:
    opposite the door that leads down to the cavern is the door that leads up to the balcony- Door Upper- where you can get the golden sleeve
    I think I have you open it 78 degrees? so maybe that's what you missed?

    cavern stuff:
    yes, they may be above the terrain, that's one of the reasons we turn them off until you are inside the temple
    if they are on, you probably won't see them from the top because the faces for the cavern are on the inside
    but, if you baked the light with the cavern on, the trees and the terrain would get the shadow!

    tree:
    use the leaf material BigTree_Leaves and BigTree_Branches, you will need to load it into the leaf groups/nodes
    I do remember it not loading the material occasionally, but it comes in with the TreeGenerator package so you should be able to find it

    trigger group:
    make sure the fpc is triggering the colliders and that they are all set to is trigger
    if the terrain drops, there should be nothing left to block you
    maybe try deactivating it during the game to see if the terrain or something else is the problem

    hope that helps-

    Sue


  9. Location
    UK
    Posts
    124
    Hi Sue

    I'm enjoying your book and have got as far as Chapter 10. Here I have a problem!
    function LookUpState(object : GameObject, currentState : int, picker : String)
    {
    var element : int = 0; // Variable to track the element number for a match
    // Check the passed in cursor texture to see if it is the default cursor; rename it if so
    if (picker == gamePointer.GetComponent (CustomCursor).defaultCursor.name)
    var matchCursor : String = "default";
    else
    matchCursor = picker;
    print ("Object: " + object.name);
    print ("State: " + currentState);
    print ("Picker: " + picker);
    for (var contents : String in stateArray [currentState])
    {print ("Contents " + contents);
    // Split the contents into a temporary array
    var readString : String[] = contents.Split (",".Chars[0]);
    // If there is a match for the cursor...
    if (readString[0] == matchCursor)
    {
    print ("We have a match with cursor: " + matchCursor + " on " + object.name);
    //print (replyArray [currentState][element]); // Print reply that corresponds to the matched stateArray
    // Send the correct text message off to the GameManager
    var actionMsg : String = replyArray [currentState][element];
    print (actionMsg);
    controlCenter.GetComponent(GameManager).actionMsg = actionMsg;//replyArray [currentState][element];
    // Change the object's state to the new state by calling its ProcessObject function
    var nextState : int = parseInt (readString [1]); // Convert the string to an integer
    object.SendMessage ("ProcessObject", nextState); // Send the new state to the object
    }
    else
    print ("No match for the " + object.name);
    element ++; // Increment the element counter by one
    } // End for loop

    }

    This extract is from the ObjectLookup script. I have checked it against your code and it matches it OK as does also the GameManager script. The problem is at the "controlCenter.GetComponent(GameManager).actio nMsg = actionMsg; //replyArray [currentState][element];", which gives a run time Null Reference Exception error. Try as I might I cannot sort this out; can you help?

    I have deleted the #Pragma strict code, as you suggest, to get rid of the downcast warnings.

    I have now (15/5/12) tried to access other components in GameManager, but continue to get the runtime error message. I cannot access GameManager from ObjectLookUp, and don't know why.
    Last edited by tholland; 05-15-2012 at 02:20 PM. Reason: additional information
    Best wishes

    tholland


  10. Posts
    8
    thanks Sue, it is odd about the trigger group.. I can see the terrain dropping but sometimes I am still prevented going down.. I will study this to see where the invisible block is coming from keeping me at main floor level..ground 0. There are a load of errors arising in the game manager script when pragama strict is added..they mainly refer to currentInventoryObject[x] = assignments. I think I read in postings that this directive should be commented out.

    page 779 I added animation clip to interactor.. Also added interactor and lookup script logic to the loose music glyph to place it in drawer as well as take it out again.(.a bonus, albeit worthless, game feature). The glyph that was in the drawer and the spare glyph, and activating the drawer logic took a while to sort out. Now at Menu chapter..(8 months later).

    many thanks and best regards,

    Michael.


  11. Posts
    8
    Hi Sue

    In chapter 16, I am getting an index error for playerSettings[10], for the cursorColorChange value. I finally added an UpdateSettings() call at the start of LoadPlayerSettings() function. This has eliminated the error, which I am guessing puts suitable default values into each of the array elements. These will, no doubt, be replaced by proper values when the UpdateSettings is called by the script. I'm not sure if I have just hid an underlying mistake by doing this.
    There is some divergence between the element descriptions in the declarations, and the functions. element 9 becomes element 10 on page 847 for cursorColorChange. I may have missed, or overlooked something.

    Best Regards

    Michael


  12. Posts
    1
    Hello Sue,

    Just purchase the book from Barnes and Noble and building Chapter 16 many errors are being displayed. Is there a corrected version for the book? My understand is the book was complied with Unity 3.3 and now 3.5 is out errors below show up. Or what steps will I need to proceed with correction? I have taken all the private statements out.

    -----EndCompilerOutput---------------

    - Finished compile Library/ScriptAssemblies/Assembly-UnityScript.dll
    Assets/Adventure Scripts/GameManager.js(104,45): BCE0120: 'Interactor.iElement' is inaccessible due to its protection level.

    (Filename: Assets/Adventure Scripts/GameManager.js Line: 104)

    Assets/Adventure Scripts/GameManager.js(116,40): BCE0120: 'Interactor.soundFXVolume' is inaccessible due to its protection level.

    (Filename: Assets/Adventure Scripts/GameManager.js Line: 116)

    Assets/Adventure Scripts/GameManager.js(240,41): BCE0120: 'Interactor.iElement' is inaccessible due to its protection level.

    (Filename: Assets/Adventure Scripts/GameManager.js Line: 240)

    Assets/Adventure Scripts/GameManager.js(264,56): BCE0120: 'Interactor.iElement' is inaccessible due to its protection level.

    (Filename: Assets/Adventure Scripts/GameManager.js Line: 264)

    Assets/Adventure Scripts/MenuManager.js(589,40): BCE0120: 'Interactor.soundFXVolume' is inaccessible due to its protection level.

    (Filename: Assets/Adventure Scripts/MenuManager.js Line: 589)

    Assets/Adventure Scripts/ObjectLookup.js(178,99): BCE0120: 'Interactor.iElement' is inaccessible due to its protection level.

    (Filename: Assets/Adventure Scripts/ObjectLookup.js Line: 17

    Assets/Adventure Scripts/ObjectLookup.js(198,39): BCE0120: 'Interactor.processing' is inaccessible due to its protection level.

    (Filename: Assets/Adventure Scripts/ObjectLookup.js Line: 19

    Assets/Adventure Scripts/ObjectLookup.js(288,60): BCE0120: 'Interactor.soundFXVolume' is inaccessible due to its protection level.

    (Filename: Assets/Adventure Scripts/ObjectLookup.js Line: 28


  13. Location
    Chicago
    Posts
    23
    Hi Sue,
    Finished the book (While ago actually) and integrated a third person camera and animation system (Currently adding a 'play on player' list of animations for contextual use and pickup animations).
    http://cgcookie.com/blender/images/gil/ (My third person character.)

    Thanks again for this... It's given me a starting point for a game I've wanted to make since I started in the industry a decade ago. (Stuck making first person shooters... a genre I don't particularly enjoy.) Really, really enjoyed the book.


  14. Posts
    198
    hi rwp908,

    the " inaccessible due to its protection level" message is probably from the private vars still being in a few of the scripts- just replace private with internal

    also remove the #pragma strict from the scripts- it doesn't like JavaScript arrays which we are using for our inventory

    @ JoeDGrant,
    thanks so much for the update- while the first part of the book was more for anyone new to real-time in general, the last half was definitely about learning to think, plan & problem solve with Unity, and it sounds like you're up & running! I like the character, too , btw , thanks for the link

    @ tholland,
    not sure if this could be the prob, but ,
    "controlCenter.GetComponent(GameManager).actio nMsg = actionMsg; //replyArray [currentState][element];"
    has a space at .actio nMsg
    null reference exception means it can't find something- and I assume that is the Control Center object- the object that holds the GameManager script

    in the Start function of the ObjectLookup script, you should have the line where it finds the Control Center
    controlCenter = gameObject.Find("Control Center");

    I would suggest copying the name straight out of the Hierarchy and pasting it in- you may have a trailing space character that doesn't show

    if the name is correct, the next thing I would do is add a line right after that to see if it really did fine the control Center
    print (controlCenter.name);

    and make sure you are using the same spelling all the way through - I spent enough years in the UK to spell center as centre occasionally

    also, you can always make controlCenter a public var and drag the object into it from the Hierarchy, but you'd need to do that for every object with the ObjectLookup script - which is a good reason to use the Find method

    hope that helps

    Sue


  15. Location
    Chicago
    Posts
    23
    Thanks. Been quite a while since I've done characters... been an environment/FX artist for years. I'll be posting screens when I've started actually putting levels together. I know... sci fi's a bit done, but every game I've worked on has been a contemporary shooter, so something a bit different for me artistically is proving to be really, really fun. (Modular tilesets ftw)


  16. Posts
    16
    Sue, I love your book! It really is great and has really helped me. I've been working through it the past week and basically got to Chapter 14 with relatively few issues after downloading the Errata Doc in this thread.

    I'm using Unity 3.5 on a Mac. I have been having "Null Reference Exception" issues starting at Chapter 14. I even used the "Book Project Chapter 14 Start" project to work from there (after editing the private to internal changes that you've listed in the Errata).

    I went ahead to "Book Project Chapter 16 Finished" project and tried to play it and got many Null Reference Exceptions. I've attached an image of what I'm coming across. Any suggestions on how to fix this?



  17. Posts
    1
    Hi Sue,

    I just received the book I ordered via Amazon yesterday, and I am looking forward to get started this coming weekend. But I was surprised it is not in colour as presented on Amazon. Is that correct or is it an illegal copy perhaps? I am suspicious because many pages have even faded text and images, so it is poor quality print. I didn't experience this with books from Apress before.


  18. Posts
    16
    Dricus, I have heard other complaints of this as well. You're right, it is rather unusual of Apress. Not sure where the issue lies. I've seen comments about print quality on Amazon. I'm sure Sue can help you.


  19. Posts
    198
    hi guys,

    I too was disappointed at the poor printing quality- especially after all the time I spent with all the colored screen shots!
    but I heard the same complaint from another author/friend who went with a different publisher, so maybe it's just a sign of the times
    I thought I was doing well to get a colored screen shot for the cover rather than a piece of sliced fruit

    @ mike274,
    I just tried updating my chapters 14 & 16 & I'm not getting that error.
    it looks like maybe it's not "finding" the other objects
    I wonder if it's a mac thing? there shouldn't be any differences but you never know

    were you getting the " inaccessible due to its protection level" message before you changed the privates to internals?

    also, I noticed that sometimes the scripts refuse to update- saw that after I change a text string- had to rename the variable before it updated the string properly

    Sue


  20. Posts
    16
    Sue, I'm not sure of the problem. I'm going to download the source files again. Maybe somehow it got corrupted? (Not likely, but who knows?) I was getting the " inaccessible due to its protection level" message but I made all the changes as per the Errata page.

    I really wouldn't think the mac thing would cause an issue. I'm stumped. I spent a few hours with it this afternoon, but I'm lost as to how to fix it.

Page 11 of 19 FirstFirst ... 910111213 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •