Unity Community


Page 58 of 119 FirstFirst ... 848565758596068108 ... LastLast
Results 1,141 to 1,160 of 2379

  1. Posts
    6,315
    @baz, double and triple check your appId, bundle ID, provisioning profile and all the other setup from Facebooks docs.


    @manaschew, there is no way to have credentials not cached by iOS. iOS devices are single user so they cache information as such. The logout method destroys the access token locally but it must still expire on Facebooks servers before it is fully unusable.


  2. Posts
    15
    Hello,

    I have both the Twitter and the Facebook plugin working great for our game. Thank you for that.

    My question is this, and I know looking into the graph API might give me some answers. Is it possible to post to another users page or wall? We would like to have users post to our developer page to certain albums preferably.


  3. Posts
    6,315
    @priznut, it sounds like it should be possible. You will want to check the Graph API docs to be certain though.


  4. Posts
    15
    Quick follow up question. When posting an image to an album. I noticed you are missing "/photos" at the end of the albumID. The Facebooks docs list that as a requirement to post images. Is that correct?

    Secondly, when using the postImage( string pathToImage, string caption, string albumId ), is that some where being hardcoded to point to the current user on your end?

    We are having no errors appear when we post at the correct Album ID for our app page on Facebook. But we see no results. We tested posting messages and so on using their developer tools, and those work. But for some reason using postImage to specific albums is not working. Yet postImage to a user's wall works perfectly.


  5. Posts
    6,315
    @priznut, none of the methods in the Facebook class are any type of magic. They are all plain old Graph requests. The postPhoto method follows Facebooks documentation guideline for posting an image to the mobile uploads album. You will have to consult Facebooks documentation for the required permissions and parameters for the request.


  6. Location
    Melbourne, Australia.
    Posts
    212
    I have a random issue.

    Everything was working fine, then one day I start crashing each time I build on launch. The problem seems to be with FacebookManager.mm

    Instance method '-handleOpenURL:' not found (return type defaults to 'id')

    FacebookManager.mm
    Code:  
    1. - (void)applicationDidFinishLaunching:(NSNotification*)note
    2. {
    3.     // did we get launched with a userInfo dict?
    4.     if( note.userInfo )
    5.     {
    6.         NSURL *url = [note.userInfo objectForKey:UIApplicationLaunchOptionsURLKey];
    7.         if( url )
    8.         {
    9.             NSLog( @"recovered URL from jettisoned app. going to attempt login" );
    10.             [self handleOpenURL:url];
    11.         }
    12.     }
    13. }

    Failed to load AOT module 'mscorlib' while running in aot-only mode.

    I have rebuilt, deleted app from device, deleted app from device via xcode organiser, reimported plugin, restarted both Mac and iOS device, deleted xcode builds etc

    Any ideas?


  7. Posts
    6,315
    @pip, everytime I have seen that error doing a fresh build in Unity then doing a Build->Clean in Xcode has cleared it up.


  8. Posts
    2
    I am using the plugin version iOS 1.4.3. with unity 3.5.3 and export to xcode 4.4.1. The twitter part works fine. But the Facebook park is not working well.

    1. The Login button switch to facebook app and does not return to the unity app. In the unity app i have to login again using the web interface.
    2. Once login, i could post with the "custom feed dialog", but other such as "post message" and "post image" is not working.
    3. Only one time the "Post image" is working but only post black image on facebook.

    Please help.


  9. Posts
    6,315
    @gadget, 1. If Facebook is not reopening your app you either didn't properly setup your Facebook app or you didn't properly setup your URL scheme.

    2. Refer to Facebooks documentation for the required permissions for each method. You have to request the permissions you need at login.

    3. postImage will post the exact image you pass to the method. Make sure you vary the caption and use a legit image and check the completion handler for the error message Facebook returns to you


  10. Location
    Melbourne, Australia.
    Posts
    212
    Quote Originally Posted by prime31 View Post
    @pip, everytime I have seen that error doing a fresh build in Unity then doing a Build->Clean in Xcode has cleared it up.
    Thanks Prime31,

    This seems to have resolved the crashing, but I need to clean it every time I build as it keeps coming back. Any idea why?


  11. Posts
    6,315
    @pip, no idea. If you can reproduce open a bug report with Unity.


  12. Location
    Melbourne, Australia.
    Posts
    212
    Hey Prime,

    Just a little correction, it no longer crashes or causes the AOT mscorlib error when launching. It just comes up with this warning in xcode.



  13. Posts
    6,315
    @pip, that is normal. Look about 3 lines down and you will see the method.


  14. Location
    Melbourne, Australia.
    Posts
    212


  15. Location
    Melbourne, Australia.
    Posts
    212
    Hey Prime,

    Just hoped you could help confirm this is a good way to go about posting on the walls, in terms of loggings, valid sessions and valid tokens.

    So in psudocode ~


    Startup

    1) initialise on start up.

    Posting to wall

    1) if session is not valid and permissions not set - login with permissions
    2) if session is not valid and permissions set - just log in
    3) wait for login successful callback if necessary
    4) post to wall with showDialog

    Do I need to be worried about getting tokens, token expiring or password changes?

    Thanks


  16. Posts
    6,315
    @pip, you of course need to be concerned with tokens expiring. Face books documentation has some information you will want to go over with regard to session management.


  17. Posts
    479
    i'm going nuts with social networking plugin for Android
    anyone knows what to type on: "Android Class Name" on facebook page for the android settings?

    I typed in: com.unity3d.player.UnityPlayerProxyActivity
    but it doesn't seem to like it. I also tried adding my package name so:
    es.echoboom.dibudibu/com.unity3d.player.UnityPlayerProxyActivity
    and same luck, anyone knows what's looking for?



  18. Posts
    92
    {!} Assets/Scripts/SetupScript.js(557,29):BCE0019: 'isLoggedIn' is not a member of 'FacebookBinding'.

    Um. Wat?

    Says here that it is.
    I looked through the script and it looked like it is really facebookIsLoggedIn, but I tried it and that didn't work either.

    Why would I be getting this error? Are we not supposed to use FacebookBinding.isLoggedIn() now, and those docs are old?

    Here's how I got the error:

    if (FacebookBinding.isLoggedIn())
    {
    fbBoxRenderer.enabled = true;
    }
    else
    {
    fbBoxRenderer.enabled = false;
    }


    update: I just tried to work around this by checking FacebookBinding.getLoggedinUsersName(), and it's saying that doesn't exist either- same error. What is up with this?
    Last edited by Kiloblargh; 08-14-2012 at 07:58 PM. Reason: But wait; there's more—


  19. Location
    Melbourne, Australia.
    Posts
    212
    I'd love if someone could provide some assistance here. I am banging my head against a brick wall for a day and half.

    There seems to be a bug, if your token expires or do any action which causes your token to expire such as changing your password or deleting app permissions then things break.

    What seems to happen is that there is no way to tell if the token expires, and Facebook try to handle itself by asking you to login again but this causes a The operation couldn’t be completed. (NSURLErrorDomain error -999.) which is apparently caused because the showDialog was interrupted to show the authentication dialog. Now most stackoverflow, facebook bug submissions post that the fix is to filter it.

    Code:  
    1. if (!(([error.domain isEqualToString:@"NSURLErrorDomain"] && error.code == -999) ||
    2.         ([error.domain isEqualToString:@"WebKitErrorDomain"] && error.code == 102))) {
    3.         [self dismissWithError:error animated:YES];
    4.     }

    The code above is the apparent fix, which is adding the if error.code == - 999.

    This doesn't help though as the showDialog (feed / publish dialog) shows up but says "An error occurred. Please try again later." All subsequence attempts to post to wall results in the same error.

    I've tried doing /me pings to the server, getAppAccessToken, isValidSession, logging in each attempt, lots of other stuff. I've been googling the issue, reading the facebook documentation, stack overflows etc etc.

    I cant seem to find a way to stop the logging bug, or to check to see if the token is expired before doing a post to wall.

    Any help would be greatly appreciated!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •