Unity Community

Page 46 of 119 FirstFirst ... 3644454647485696 ... LastLast
Results 901 to 920 of 2379

  1. Posts
    @Jtown, I just pushed an update with the following change: added automatic conversion of Unicode characters for all Graph API methods

  2. Location
    Dallas, TX
    Quote Originally Posted by Prime31 View Post
    @Jtown, I just pushed an update with the following change: added automatic conversion of Unicode characters for all Graph API methods
    Sweet thanks. Works perfectly.

  3. Location
    Midlands, UK
    Has anybody else noticed that in ios 5.1, if you log in to Facebook then immediately call showPostMessageDialog the dialogue box immediately closes? If you call showPostMessageDialog a second time it works and you can post.

    This only happens in ios 5.1, ios 5.0 and lower it's fine. Would like to know if anybody else can reproduce this behaviour.

  4. Location
    Hi Prime.
    After revising your answer for the cause, I moved normally. Thank you!

  5. Posts
    Hi prime! making progress with the twitter binding, however when I attempt the following:

    (with the aim of getting output like)

    userName : userTweet
    1. void twitterHomeTimelineReceived( ArrayList result )
    2.     {
    3.         string resultText="";
    5.         for(int i=0;i<6;i++)
    6.         {
    7.             Hashtable twitterData=(Hashtable) result[i];
    8.             string newString= twitterData["screen_name"].ToString()+": "+ twitterData["text"].ToString();
    9. .
    10. .
    11. .

    I get results like:
    : some tweet here
    meaning the "screen_name" is null for some reason while "text" works- how do I fix this?

    Okay here is an extract from the logger you recommended:
    1. n_reply_to_user_id_str:
    2. in_reply_to_status_id:
    3. text: Ghj
    4. created_at: Tue May 01 13:54:13 +0000 2012
    5. in_reply_to_status_id_str:
    6. source:  /////////redacted
    7. in_reply_to_user_id:
    8. retweet_count: 0
    9. contributors:
    10. in_reply_to_screen_name:
    11. user: profile_image_url_https: https://si0.twimg.com/profile_images/490147714/matrix_normal.jpg
    12. show_all_inline_media: False
    13. contributors_enabled: False
    14. lang: en
    15. profile_use_background_image: True
    16. profile_sidebar_border_color: C0DEED
    17. profile_background_image_url_https: https://si0.twimg.com/images/themes/theme1/bg.png
    18. default_profile_image: False
    19. geo_enabled: False
    20. following: False
    21. name: yuriy nikshych
    22. profile_image_url: http://a0.twimg.com/profile_images/490147714/matrix_normal.jpg
    23. profile_link_color: 0084B4
    24. profile_text_color: 333333
    25. utc_offset:
    26. created_at: Wed Feb 04 19:02:44 +0000 2009
    27. protected: False
    28. follow_request_sent: False
    29. id_str: 20080308
    30. favourites_count: 0
    31. notifications: False
    32. profile_background_color: C0DEED
    33. profile_background_tile: False
    34. id: 20080308
    35. listed_count: 0
    36. friends_count: 7
    37. is_translator: False
    38. default_profile: True
    39. profile_sidebar_fill_color: DDEEF6
    40. screen_name: yuriythebest
    41. profile_background_image_url: http://a0.twimg.com/images/themes/theme1/bg.png
    42. followers_count: 15
    43. time_zone:
    44. verified: False

    I've tried both "name" and "scene_name" but they seem to be null in Unity, while the logger says they have values

    I've even tried

    1. if(twitterData["name"]!=null)
    2.                 newString+=twitterData["name"].ToString()+": ";
    3.              newString+=  twitterData["text"].ToString();

    but that leads to the same result as before

  6. Posts
    @yuri, are you certain the screen_name property is in the root of the object? Judging by the log and Twitters documentation (https://dev.twitter.com/docs/api/1/g.../home_timeline) it would appear screen_name is not a root level key but is nested in another hash.

  7. Posts
    Quote Originally Posted by Prime31 View Post
    @yuri, are you certain the screen_name property is in the root of the object? Judging by the log and Twitters documentation (https://dev.twitter.com/docs/api/1/g.../home_timeline) it would appear screen_name is not a root level key but is nested in another hash.
    indeed good sir that was the case, many thanks!

  8. Posts
    For Facebook...

    Is 'isSessionValid()' same as 'isLoggedIn()' ?
    I know the latter was dropped, but is it okay to use the session in replacement of this?

    Also, I just caught isSessionValide turn to TRUE even though I wasn't able to login properly. Investigating this one.

  9. Posts
    @shadow, isSessionValid will return true as long as there is a valid access token present that has not expired.

  10. Posts
    Quote Originally Posted by Prime31 View Post
    @CHICAN0, please have a look at the demo scene. There is an example of exactly what you are trying to do already in there.

    Can you tellme exactly whats the example or code line to get MY id into a variable please... Thanks.

  11. Posts
    @chicano, the example does exactly what you are looking for. It grabs the user id and stores it in an instance variable.

  12. Posts
    Hey there,

    I've been trying to post a tweet, but when I do so I get :

    SendMessage: object TwitterManager not found!

    The tweets are posted, but I can't notify the user as Action twitterPost is not triggered.

    How can I solve that please ?

  13. Posts
    @kuroe, it looks like you do not have the TwitterManager prefab in your initial loading scene. Add it and the error will be resolved.

  14. Posts
    @Prime31, thanks, that did the trick ! Surprisingly the FacebookManager is working perfectly without having a prefab instance in the scene.

  15. Posts
    Hi Prime31,

    Any idea on how to fix " Unknown identifier: 'HTTPVerb'."?

    I'm coding in UnityScript and here's a snippet of my code:

    1. var postParam : Dictionary.<String, Object> = new Dictionary.<String, Object>();
    2. postParam.Add("message", "Test Message");
    3. postParam.Add("link", "http://www.google.com");
    4. postParam.Add("name", "Link Name");
    5. postParam.Add("caption", "Post Caption");
    6. postParam.Add("description", "A very long description");
    8. Facebook.instance.graphRequest("123456789/feed", HTTPVerb.POST, postParam, PostedToFriendsWall);

  16. Posts
    oh nevermind, Got it working, just added

    1. import Prime31;

    on top of script.

  17. Posts
    How big can a screenshot be when I upload it to facebook? Cause If we try to upload a screenshot it doesn't work. It just doesn't get uploaded. But if we upload a really low res image it works.

  18. Posts

    Hi Prime,

    I am having some problems integrating Facebook into my game. I did managed to post to the wall before . However today I am getting this error from the Xcode:

    ghashtable.c:294: assertion 'hash != NULL' failed,

    It does one of the following every time i try to post : it asks for permissions and redirects me back or redirects me to Facebook or doesn't even ask for permissions and redirects right back. The Problem is that it keeps asking for permission(or just redirecting and going back) even when it supposedly got it . So i never get to actually posting.

    I just noticed this behavior today, when i initially put in the code it seemed to work fine. I did not change the code...

    any ideas what could be causing it?

    my code:

    public void FacebookButtonPressed1()
    FacebookBinding.init( "*********" );
    //Login Try
    bool isLoggedIn = FacebookBinding.isSessionValid();
    if (!isLoggedIn)
    var permissions = new string[] { "publish_actions", "user_games_activity" };
    FacebookBinding.loginWithRequestedPermissions( permissions );

    Facebook.instance.postMessage( "1234", completionHandler );

  19. Posts
    @eric, you will need to check Facebooks docs for the image size constraints.

    @katawa, have you tried deleting your app an reinstalling? That often clears up odd issues like this whn testing.

  20. Posts
    Yes, I deleted it and reinstalled it several times. No luck...

    Perhaps it is somehow connected to the app settings in Facebook. I noticed that if the app is set to native iOS then i do not at all get to the "permission asking" state, it's just redirects to Facebook and then redirects back (no posting).

    If it set to a web app then i get to see the permissions window, i get to allow it but that is all. The second time it takes me to the permissions again,never get to actually posting to a wall.

    It didn't happen few days ago , when i initially integrated the plugin. Perhaps it is something else in the Facebook app settings i changed unintentionally...

    I will really appreciate any help on fixing this issue.


Page 46 of 119 FirstFirst ... 3644454647485696 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts