Unity Community


Page 25 of 119 FirstFirst ... 1523242526273575 ... LastLast
Results 481 to 500 of 2379

  1. Location
    Orlando, FL
    Posts
    68
    Hey everyone,

    I have problem with the facebook part of the plugin. It worked a few days ago but recently, when I log into the app and try to get an access token through FacebookBinding.login, i get an error "Cannot open page, Safari cannot open the page because the address is invalid". Does anyone know how to solve this?

    I'm not sure if this is related to the login problem found two pages ago.


  2. Posts
    6,315
    @John, double check your plist setup and be sure to delete the app from your device between tests.


  3. Posts
    4
    Hi!

    I am having som problems with the social plugin for iOS. I wrote a question for it here:

    http://answers.unity3d.com/questions...31-social.html

    It seems i cant login when using the facebook app on the device, but if i remove the app it works fine. Any pointers?

    Thanks,


  4. Posts
    6,315
    @Niklas, it sounds like you may have rejected the login at some point while testing. You may have luck going to the Facebook website in your user account and digging through their permissions. Find your app in there and just remove anything you find to get a fresh start.


  5. Posts
    20
    All of a sudden today, my request to friends/ids now returns a hash table instead of array list and the data I get back seems to be incorrect.

    Eg:

    previous_cursor_str: 0
    next_cursor: 0
    previous_cursor: 0
    next_cursor_str: 0
    ids:
    --------------------

    --------------------

    --------------------

    --------------------

    --------------------

    --------------------


    I get no ids and just these lines :/ quite strange considering yesterday it was fine. Anyone else experience this? (thinking it's more of a twitter api issue than the plugin though )


  6. Posts
    6,315
    @Griffith, there was a change that went live on Twitters servers yesterday. Check their dev portal or Google Group for the details. If I recall it has something to do with passing the cursor to the method.


  7. Location
    England
    Posts
    76
    We intend on uploading the binary to our game shortly, however I was doing some last minute checking on what might get the app rejected and found this blog post: http://gtproductions.net/blog/ways-t...pp-store-tips/ (although it is from 2009 so Apple's requirements may be different now?)

    It mentions that an app can be rejected for not notifying a user that there info will be sent over a network and I was wondering whether this has affected anyone when they try and log in or post messages with the functions available in this plugin. And whether it's made anyone's apps get rejected.

    Here's the text from the site I'm on about;

    "
    14.) Handling user data
    If you collect user information and the data is sent over a network, you need to explain to the user what will happen to their data and give them an option to opt out. For example, leaderboards require certain notification to the user that even their bogus name used on the high score boards will be sent over the internet and seen by others.
    "

    Prime do you know anything about this?


  8. Posts
    6,315
    @jasonh, I have never seen an app rejected for this nor have I seen any app notify me that it was going to send data out. I wouldn't worry much about it.


  9. Posts
    104
    Hi, sorry for newbie question. Just bought your social networking plugins yesterday. So the problem is like this :
    1. I build the apps from unity3D ver 3.4.1f5
    2. A dialogbox came up "SocialNetworking Unity support successfully integrated!
    3. I run xcode ver 4.0.2 and plug my iphone and run the apps from xcode
    4. when the xcode build the apps ... I got an error message :


    What should I do ? Where am I doing wrong ? thx
    Unity3D - Mac OS X - iPad - iPhone - iTouch - psi-studio.com


  10. Posts
    6,315
    @petero, assuming you are building against iOS 5 I would suggest closing Xcode completely and doing a Build followed by Replace from Unity. It looks like you may have just gotten a bad build.


  11. Posts
    104
    @prime31, am I need to upgrade to iOS5? I have close the xcode and delete all file inside and build from the beginning. And the error message still the same. I am using Unity3D indie for iOS version, and below this is my xcode and unity3d version.





    unity3D ver 3.4.1f5
    xcode ver 4.0.2

    Please help .... thx
    Unity3D - Mac OS X - iPad - iPhone - iTouch - psi-studio.com


  12. Posts
    6,315
    @petero, you are using an old version of the iOS SDK. You must build against iOS 5.


  13. Location
    Cambridge UK
    Posts
    141
    I just tried to import the Social Network package into my project and there's a problem with there being 2 MiniJSON files. Deleting the one in the social network plugin causes the compiler to complain that MiniJSON does not contain a definition for 'jsonDecode', deleting the one in the UIToolkit plugin causes the compiler to complain that there's no definition for 'JsonDecode'. The difference being lower case j and upper case J.

    Presumably the latest version of UIToolkit has been updated to conform to your lower case methods. Unfortunately it's far too late for me to just update UIToolkit for this project, i've made numerous changes and i dread to think of all the things that would break if i do an update now.

    All my attempts of converting either plugin produce more errors that I just dont' understand.

    What do you suggest I do?


  14. Posts
    6,315
    @Matkins, you have an old version of UIToolkit for sure. The easiest path to fix things is to delete the UIToolkit MiniJson.cs file and leave the Social Networking one. There will just be a copule minor compilation errors left and they are easily fixed by changing the capital 'J' to lowercase 'j' (MiniJson.jsonEncode/Decode).


  15. Location
    Cambridge UK
    Posts
    141
    Ok, it wasn't as painful as I feared. All sorted, Cheers.


  16. Location
    Southampton, UK
    Posts
    48
    I've been using the SocialNetworking plugin for a while, but as I was out of date with three of the plugins (last updated August) I thought I'd be "tidy" and start over with the plugins, and import them from scratch.

    I'm now getting the following exception in XCode as soon as the plugin is referenced in code...
    Code:  
    1. 2011-11-08 18:50:43.608 testapp[9795:707] -[Facebook initWithAppId:andDelegate:]: unrecognized selector sent to instance 0x7a5c330
    2. 2011-11-08 18:50:43.630 testapp[9795:707] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[Facebook initWithAppId:andDelegate:]: unrecognized selector sent to instance 0x7a5c330'
    I have of course re-attached the SocialNetworkingManager prefab to the scene, added the Facebook app ID into the Info.plist Additions, chmod +x'd the PostprocessBuildPlayer scripts (as recommended by the Plugin Troubleshooter) and output to a fresh (replaced) XCode build folder, but no luck as yet.

    I'm sure I've just forgotten something silly - any ideas?

    Thanks,
    Dan


  17. Posts
    6,315
    @DarkJedi, it looks like you still have some old files hanging around in there. Be sure to do a Build followed by Replace to get a fresh Xcode project. It is often a good idea to do a Product -> Clean when large changes are present as well to clear out the object cache in Xcode.


  18. Location
    Southampton, UK
    Posts
    48
    Thanks!
    Starting over a second time with the plugins, hosing the build directory (not just replace), running an XCode clean and shouting at the screen seems to have resolved it, and I'm up and running again

    For others with similar symptoms, I think shouting at the screen is what fixed it.


  19. Posts
    20
    Hey Prime, back to the issue I was having about people logging out etc. It seems that even if it's the first login for anyone, the App has to be restarted before it can do anything that requires authorisation.

    For example if someone buys the app and logs in they will have to restart the App before my requests work.

    Any ideas if this is something I'm doing wrong? I've seen other games that don't require a restart. There's no log out call made it's just the first time login.

    Thanks

    (Oh btw it's a twitter login not facebook)


  20. Posts
    6,315
    @Griffith, are you seeing that behavior with the demo scene? I can't reproduce it on my end.

Page 25 of 119 FirstFirst ... 1523242526273575 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •