Unity Community


Page 30 of 200 FirstFirst ... 2028293031324080130 ... LastLast
Results 581 to 600 of 3986

  1. Posts
    6,306
    @mforsyth, you sure can. Just grab the download with iOS 4.3.1 and Xcode 3.x and reinstall. There is an uninstall script that comes with every version of the SDK in the /Developer/Library folder. I believe it is called uninstall-devtools if my memory serves me.


  2. Location
    Melbourne, Australia
    Posts
    1,400
    I dont have the luxury of going back to xCode 3.x... I am stuck on 4.x, so what steps do I need to take to get the Social Networking plugin working? I am getting Apple Mach-O arm6/arm7 errors everywhere.

    Code:  
    1. Undefined symbols for architecture armv7:
    2.   "__facebookShowPostMessageDialogWithMessage", referenced from:
    3.       RegisterMonoModules()     in RegisterMonoModules.o
    4.   "__facebookGraphRequest", referenced from:
    5.       RegisterMonoModules()     in RegisterMonoModules.o
    6.   "__twitterIsLoggedIn", referenced from:
    7.       RegisterMonoModules()     in RegisterMonoModules.o
    8.   "__facebookGetLoggedinUsersName", referenced from:
    9.       RegisterMonoModules()     in RegisterMonoModules.o
    10.   "__twitterLogin", referenced from:
    11.       RegisterMonoModules()     in RegisterMonoModules.o
    12.   "__facebookPostMessageWithLinkAndLinkToImage", referenced from:
    13.       RegisterMonoModules()     in RegisterMonoModules.o
    14.   "__facebookInit", referenced from:
    15.       RegisterMonoModules()     in RegisterMonoModules.o
    16.   "__facebookGetFriends", referenced from:
    17.       RegisterMonoModules()     in RegisterMonoModules.o

    etc....

    Ok, it seems the postprocessor is just busted with Xcode 4. I have manually moved the files over, but I am unsure if there is anything else that needs to be done as the applescript file is encrypted
    Last edited by Seon; 04-06-2011 at 08:18 PM.
    Seon :: Lead Code Monkey
    3 Sprockets :: http://www.3sprockets.com :: @3sprockets
    http://cubemen2.com :: http://fightthedragon.com :: Adventurers Wanted!


  3. Posts
    6,306
    @Seon, redownload the package using your original download link. Be sure to delete the plugin folder from your Unity project before importing (just to be safe). The updated package has the beta Xcode 4 support which seems to be stabilizing nicely now.


  4. Location
    Melbourne, Australia
    Posts
    1,400
    Hi Mike, thanks

    Grabbed that version and all is building and compiling properly now... but only issue is that the...

    Code:  
    1. SocialNetworkingManager.facebookReceivedUsername += facebookReceivedUsername;

    callback is not working. It's never called and my fb name is never returned

    This worked fine on previous plugin and xcode 3. Any ideas?

    I lied... My fault! Ignore this...
    Last edited by Seon; 04-06-2011 at 09:57 PM.
    Seon :: Lead Code Monkey
    3 Sprockets :: http://www.3sprockets.com :: @3sprockets
    http://cubemen2.com :: http://fightthedragon.com :: Adventurers Wanted!


  5. Posts
    6,306
    @Seon, do you see any clues in the console? Perhaps you forgot to include the SocialNetworkingManager prefab? Are you making sure to call getLoggedinUsersName()?


  6. Location
    Melbourne, Australia
    Posts
    1,400
    Quote Originally Posted by Prime31 View Post
    @Seon, do you see any clues in the console? Perhaps you forgot to include the SocialNetworkingManager prefab? Are you making sure to call getLoggedinUsersName()?
    That's exactly what I forgot to re-add... "getLoggedinUsersName()" - All good now, thanks for your super support - Once again!
    Seon :: Lead Code Monkey
    3 Sprockets :: http://www.3sprockets.com :: @3sprockets
    http://cubemen2.com :: http://fightthedragon.com :: Adventurers Wanted!


  7. Posts
    54
    I'm back on iOS 4.3.1 and Xcode 3.x but I'm still getting errors trying to use the Native Toolkit.

    Code:  
    1. The Info.plist for application at /Users/mark/Project/xcode/build/App.app specifies a CFBundleExecutable of App, which does not exist
    2.  
    3. Undefined symbols for architecture armv6:
    4.   "__nativeToolkitSetAnimationDuration", referenced from:
    5.       RegisterMonoModules()     in RegisterMonoModules.o
    6.   "__nativeToolkitDeactivateUI", referenced from:
    7.       RegisterMonoModules()     in RegisterMonoModules.o
    8.   "__nativeToolkitActivateUIWithController", referenced from:
    9.       RegisterMonoModules()     in RegisterMonoModules.o
    10.   "__nativeToolkitInit", referenced from:
    11.       RegisterMonoModules()     in RegisterMonoModules.o
    12.   "__nativeToolkitSetAnimationTypeAndSubtype", referenced from:
    13.       RegisterMonoModules()     in RegisterMonoModules.o
    14. ld: symbol(s) not found for architecture armv6
    15. collect2: ld returned 1 exit status

    Everything is fine without it, but as soon as I import it I get those errors. Hopefully I missed something.


  8. Posts
    6,306
    @mforsyth, the files aren't getting copied into your Xcode project. This is almost always because the PostprocessBuildPlayer* scripts are not executable. Try making them executable (chmod a+x PostprocessBuildPlayer*) and then do a Build followed by Replace.


  9. Posts
    54
    yup, that works! And that explains why the icon in unity for the PostprocessBuildPlayer_NativeToolKit was different than the others.


  10. Location
    Omaha, Nebraska
    Posts
    26
    Hi I've been trying to implement your Mobclix plugin into our game. However I get a strange issue. Whenever I initialize Mobclix the movies I play in Unity are suddenly being played in portrait, when they're originally supposed to be played in Landscape Left.
    Last edited by xcodeusa; 04-08-2011 at 10:17 AM.
    --
    App Developer
    SkyVu Pictures
    xcode@skyvu.net
    http://www.skyvu.net


  11. Posts
    6,306
    @xcodeusa, are you setting the iPhoneKeyboard to autorotate to only landscape? Unity's handling of orientation is wonky to say the least but setting the iPhoneKeyboard often works around it.


  12. Location
    Omaha, Nebraska
    Posts
    26
    Thanks for the quick reply, I'll try that asap.
    --
    App Developer
    SkyVu Pictures
    xcode@skyvu.net
    http://www.skyvu.net


  13. Posts
    85
    I am not able to post Image to FaceBook and not able to get logged in on twitter using Prime31 Social Integration Plugin

    Please Reply the solution to problem
    qamarengineer



  14. Posts
    16
    Hi Prime31,

    I'm try to use your system for the iAds but the xcode give me 10 times this errors:

    for member 'interstitial' in 'self', which is of non-class type 'AdManager*'

    Can you suggest me how to resolve it?

    Regards,

    Riccardo


  15. Posts
    6,306
    @Richard, make sure you are building against the latest SDK and that your Base SDK is set to the highest available (4.3.1 currently). Your error sounds like it is due to not being up to date with the latest SDK which bow has support for interstitial ads.


  16. Location
    Barcelona, Spain
    Posts
    160
    Quote Originally Posted by Prime31 View Post
    @mforsyth, the files aren't getting copied into your Xcode project. This is almost always because the PostprocessBuildPlayer* scripts are not executable. Try making them executable (chmod a+x PostprocessBuildPlayer*) and then do a Build followed by Replace.
    Where do I have to execute the chmod line?

    EDIT: Ok I found it. I had to go to the project folder Assets/Edit from the Terminal and execute chmod a+x PostprocessBuildPlayer*
    Last edited by Barbur; 04-11-2011 at 03:38 AM.


  17. Location
    Barcelona, Spain
    Posts
    160
    Hello all,

    Maybe someone found the same problem as me... I have a test application with one NON-Consumable inapp working right. I can buy it well, retrieve the saved transactions without any problem but when I try to validate the receipt it gives me this error:

    Receipt validation failed with statusCode: 21002
    On the validation call I added the test boolean to true and I verified that the saved transaction used to validate is correct.

    Any idea someone?


  18. Location
    Omaha, Nebraska
    Posts
    26
    Hi Prime31, the movies are still being played in portrait despite trying to set autorotate in only one orientation. Could it be my version of Xcode? 3.2.5?
    --
    App Developer
    SkyVu Pictures
    xcode@skyvu.net
    http://www.skyvu.net


  19. Posts
    6,306
    @xcodeusa, did you destroy the Mobclix banner before playing the movie? do you have your iPhoneKeyboard orientations set? have you observed the black border to see what orientation it is in (that is usually a good clue as to what orientation other views will end up)?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •