Unity Community


Results 1 to 12 of 12

  1. Posts
    5

    Linux Mouse Wheel not working

    Hi All

    I've discovered that the mouse wheel doesnt work in the linux build of unity3d.

    I see that this has been reported, but, does anyone know if there's a fix? or even going to be?

    Thanks in advance

    Mike

  2. Volunteer Moderator
    Posts
    23,706
    Coincidentally, I just now submitted a bug report for that. Also Event.current.clickCount doesn't work in Linux either; submitted a bug for that yesterday and got a confirmation that they could reproduce that and sent it for resolution with the developers.

    --Eric
    SpriteTile: new tile system that works seamlessly with Unity 4.3 sprites
    FlyingText3D: dynamic 3D text with TTF fonts | Vectrosity: fast & easy line drawing
    Nifty utilities! Stitch terrains together - runtime model importing - file browser - fractal landscapes


  3. Posts
    5
    Ah Awesome! its enough to know they're working on a fix

    Mike

  4. Volunteer Moderator
    Posts
    23,706
    Well, I don't know about that. They do seem to be working on a fix for the clickCount bug. I haven't gotten any response yet about the scroll wheel bug, but I just submitted it. And it's Friday.

    --Eric
    SpriteTile: new tile system that works seamlessly with Unity 4.3 sprites
    FlyingText3D: dynamic 3D text with TTF fonts | Vectrosity: fast & easy line drawing
    Nifty utilities! Stitch terrains together - runtime model importing - file browser - fractal landscapes


  5. Posts
    5
    lol fair enough


  6. Location
    UK
    Posts
    161
    I'm getting the mousewheel problem in Linux having compiled from Unity 4.1 on Windows.

    This didn't happen in Unity 4.0.

    Furthermore, if you maximise or resize a Unity3d window in Linux (which started windowed), the mouse x,y positions no longer seem to tally up correctly with what they should be... it's as if Unity is still working to the original window size.


  7. Posts
    434
    I also can't get moushewheel to work on Linux, under Unity 4.1, I'm having this problem since Unity 4.0 and reported a bug ages ago.
    Is anyone updating the Linux build ?


  8. Posts
    413
    I've been getting reports from users about this as well. I suspect the problem is with control indexing, as reports indicate that the wheel down is apparently acting as a button, and wheel up is acting as wheel down.

    This post explains it in more detail:

    http://forum.kerbalspaceprogram.com/...l=1#post403594

    Cheers
    The limit of the willing suspension of disbelief for a given element is directly proportional to the element's coolness.


  9. Location
    UK
    Posts
    161
    Disappointing that several months in the mouse issues continue...


  10. Location
    Silicon Valley CA
    Posts
    44
    Quote Originally Posted by HarvesteR View Post
    I've been getting reports from users about this as well. I suspect the problem is with control indexing, as reports indicate that the wheel down is apparently acting as a button, and wheel up is acting as wheel down.

    This post explains it in more detail:

    http://forum.kerbalspaceprogram.com/...l=1#post403594

    Cheers
    Heya HarvesteR! Care to share details of the workaround you used for this in KSP?

  11. QA Guy



    Location
    Berlin
    Posts
    126
    That issue was fixed internally and will be available in one of the upcoming 4.X releases.


  12. Location
    Silicon Valley CA
    Posts
    44
    Good to hear! Hopefully that means 4.1.x -- we like our fixes served with minimal regressions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •