Unity Community


Results 1 to 6 of 6

  1. Posts
    178

    C4D FBX Imports Without Material

    I should have said C4D FBX Imports Without UVs. *.C4D files as well.

    I have been fighting this for five days, please help!

    I have used Unity for several years. Few weeks ago I built a new computer (OSX).

    Did a fresh installation of Unity 3.5.6f4.
    Fresh install of brand new Cinema4D, R13
    I also later tried a fresh install of R11.5 that always worked for me.

    When I import the FBX, or even drop in the C4D file, the prefab contains a "no name" material with no UVs, as if the texture were just thrown on the object.

    My C4D FBX export settings are (selected only):

    Export animation (tried it on and off)
    Export textures and materials.
    Save normals.

    I've tried variations of these and all the others.
    I tried importing it into my old computer/Unity. Same problem.
    I no longer have my old C4D installation, as that HDD died.

    The only difference I can think of is that I used to do all my asset design on my PC, then copy it over to the Mac. Now I do it all on one machine (Mountain Lion).

    I have tried a brand new Unity project, brand new, and very simple, assets from C4D.
    I've played with the import settings for the prefab.
    The C4D import plugin is installed. I never needed it before because I use FBX only, but I tried it.

    I have searched the web for similar problems but have not found an answer.

    This happens with C4D 11.5 and R13.

    Am I missing a plugin for C4D? I don't remember ever needing one. This is a new computer so I don't know if I forgot some critical setting or plugin. I'm going crazy!!!

    Please help! If you need more info from me please let me know. I try not to ask for help here often but I'm out of ideas.



    UPDATE
    I have C4D 11.5 installed on an old Windows machine. THAT WORKS! I created a new scene, used FBX 6 instead of FBX 2010, then copied it into a project on the Mac.

    But that isn't an option for me. I tried installing C4D in a windows 7 VM within OSX but the mouse went crazy on me.
    Last edited by schplurg; 11-17-2012 at 08:08 PM.


  2. Posts
    6
    1. Since I'am used Cinema 4D r13 for modeling and animtion for My Unity learning project characters, I'am not use or export to FBX files anymore. Unity works more smooth and easy to manage texture with default Cinema 4D extension ( c4d )

    2. I prefer by using bootcamp to run Windows 7/8 rather than VM


  3. Posts
    178
    Thanks for the reply. I have a windows machine, plus a virtual windows machine on the Mac (I rarely use it).

    C4D files cause the same issues for me as FBX. Even If I start a new project, make a cube, add a texture and tweak the UVs, it comes out with no UVs in Unity. Sometimes the wrong texture is even applied once imported to Unity. I've tried new projects.

    Does anyone have a clue? It's probably something I overlooked, but what can it be? I have fresh installs of everything. Creating an FBX in Windows, then copying to the Mac worked. If I do the same thing in OSX I get the texture/UV problems.

    Should I just learn Blender? This is getting silly - I mean the series of C4D issues over the years is maybe a clue that C4D isn't the best tool.

    UPDATE
    Tried it again from my old Windows PC and it works. I seem to have narrowed it to the Mac version of C4D's FBX exporter.

    Does anyone know if the Cactus 3D FBX plugin would solve this? I will gladly pay $30 to fix this issue.
    Last edited by schplurg; 11-19-2012 at 04:54 PM.


  4. Posts
    178
    I am still having issues with FBX importing. Different scenario......

    I converted my old version of Daredevil Dave to run in Unity 4, 3.5x as well. Works great on the PC.

    When I use my Mac to do the same exact thing, same Unity version, same C4D version, the materials aren't created properly.

    Also...
    When I use Cinema4D on my Mac and convert to FBX, then import into Unity, the materials are messed up.

    If I use ANY Windows machine or VM to create the FBX in C4D, it works fine. Same exact settings.

    These are new installations, pretty new machines. I can't take it any more. What am I missing here?

    Please!!!???


  5. Posts
    178
    SOLVED

    Solution: Run C4D in 32bit mode on OSX. FBX does not work properly in 64 bit mode. All problems solved - the end. What a headache/joke.

    Special thanks to Cactus Dan for helping out. Check out his great C4D plugins and other goodies...
    http://www.cactus3d.com/

  6. Super Moderator
    Location
    USA - Chesaning, MI
    Posts
    1,515
    Most plugins for C4D are in 32bit even their own FBX "plugin". So stick with the 32bit version of C4D and everything will be fine in the future.

    @ph0bia - That's actually not such a good idea. In fact, the .c4d file get's converted to FBX in the background without you noticing so you may just want to export it as FBX by hand as you have more control over it via preferences.
    I am available for Freelance work! Contact me via PM or email.
    My blog: Click to open
    Twitter: Thomas Pasieka

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •