Unity Community


Page 1 of 7 123 ... LastLast
Results 1 to 20 of 124

  1. Posts
    14

    Error Launching Unity Player

    Sometime ago i installed the Unity Web Player to play a game with my friends and this error appear to me.

    "Error Launching Unity Player"

    Then i go to the error notes of the program and this appears:

    120704 19:33:48 ------------------------------------------------------------
    120704 19:33:48 Instance starting, version 3.5.3f3_044362ab147f, UNITY_WEB_ENABLE_AUTODOWNLOAD: 1, GetDisableAutoUpdates(): 0
    120704 19:33:49 Datafile http://www.monkeyquest.com/Game/Game....4.187.unity3d
    120704 19:33:51 loader: unity dll not found: C:/Documents and Settings/Andre Silva/Local Settings/Application Data/Unity/WebPlayer/player/3.x.x/webplayer_win.dll
    120704 19:33:51 Setting error display: 'Error launching Unity Player', details: 'Failed to load Unity dll.
    ', link: 1

    I go to the folder who have the .dll and i found the .dll there and this error keep appearing s:

    I have widows xp sp3, my graphic card is an ATI Radeon 9600series my processor is a pentium 4, 1GB RAM and the browser is google chrome.

    I show you some prints of the error, this keep appearing in all the unity web player games.





    Please help s:
    Last edited by contas; 07-05-2012 at 06:45 AM.

  2. Cape bearer

    Location
    UK
    Posts
    339
    Hi there,

    Just letting you know I'll be investigating this issue this afternoon, I hope to come back to you with a workaround, I at least hope to reproduce this and get it fixed for you.

    Thanks,
    Chris


  3. Posts
    14
    Quote Originally Posted by CreativeChris View Post
    Hi there,

    Just letting you I'll be investigating this issue this afternoon, I hope to come back to you with a workaround, I at least hope to reproduce this and get it fixed for you.

    Thanks,
    Chris
    Thank you i will be wainting :s

  4. Cape bearer

    Location
    UK
    Posts
    339
    Ok, I investigated this issue and it's not reproducible on a machine similar to yours.

    Have you tried reinstalling the WebPlayer? if not, please follow these instructions:

    1. Uninstall the WebPlayer via control panel -> Add/Remove programs
    2. Restart your machine
    3. Open browser and go to our website: http://unity3d.com/webplayer to download the installer
    4. Click the big blue download button
    5. Install the WebPlayer
    6. Restart browser

    Please try to play monkey quest again and see if the issue reproduces?

    Thanks,
    Chris


  5. Posts
    14
    Steel the same thing, thanks to the reply but doesn't work and i realy want to play with my friends :/

  6. Cape bearer

    Location
    UK
    Posts
    339
    Please repeat the same steps as above but this time please download the WebPlayer from here:

    http://webplayer.unity3d.com/downloa...PlayerFull.exe

    Thanks,
    Chris


  7. Posts
    14
    Same error s: this is very annoying really

  8. Cape bearer

    Location
    UK
    Posts
    339
    Hi again,

    We understand your frustration, something is preventing the webplayer_win.dll to not be loaded, and there could be many reasons to why this is happening.

    I suggest first checking the permissions on the file, so head to the location on disk of the webplayer_win.dll "C:/Documents and Settings/Andre Silva/Local Settings/Application Data/Unity/WebPlayer/player/3.x.x/webplayer_win.dll"

    Right Click -> Properties -> Security tab -> Advanced please take a screenshot of that window, it will show us the users which have permission to use the file.

    Also, additionally please check if your anti-virus has somehow blocked this file, a simple test would be to disable the anti-virus and try to play a game and see if you get the same error.

    Thanks,
    Chris


  9. Posts
    14
    Where is the Security Tab?




    Nope, with anti-virus off same thing s:
    Last edited by contas; 07-06-2012 at 09:35 AM.


  10. Posts
    19
    hi guys,ive got the same problem with contas,guys ,pls do something ,its very annoying

  11. Cape bearer

    Location
    UK
    Posts
    339
    Hi,

    Did you try all the suggestions I made? please also show a screenshot.

    Thank,
    Chris


  12. Posts
    19
    after login BSGO, when loading bar appears under the picture with Kara Thrace and Admrl Adama,in few seconds later appears a message says Error launching Unity player,under this appears 2 options to clik on,1 says install manually and the other says Error details.When clik on the second option, apppears a small window message says Failed to load Unity dll. the same happends with firefox browser.i do all the steps that descriped at the link by Graham in the following post on Unity Answers.but nothing,even i uninstall comodo internet security for prevent broken installation of player.i did all the necessary moves about this, that described in forums of BP and Unity ,even clean installation of windows XP SP3 and IE8 with all available updates in software and hardware stage or scanning my system with several antivirus-spyware programs and ccleaner.what left to do any more?guys ,do something,8 days passed when Unity problem starts

  13. Cape bearer

    Location
    UK
    Posts
    339
    @alexthan13 thanks for that info.

    The problem is we don't have a repro case, as far as we can tell only a few users are experiencing this issue, all the machines I test on work perfectly, no trace of this error, so, we are relying on you guys to help us out to find the cause which requires some patience regarding finding a fix for this.

    Please check the permissions on the webplayer_win.dll file, are you both admin users? Does this happen in all browsers? Is your XP installation fully updated with microsoft updates?

    Try installing the WebPlayer using the /Allusers flag - to do this follow these instructions (note: you need admin permissions to do this):

    1. Uninstall the WebPlayer via ctrl panal
    2. Download and save the installer to your desktop
    3. Open a cmd prompt
    4. Type cd Desktop -> press enter
    5. Type UnityWebPlayer.exe /Allusers -> press enter
    6. This will install the WebPlayer for all your users on your computer

    Importantly, the install files are now written to Program files and not your users local files.

    Restart your machine after installation completes, once booted back in, launch your browser and test to see if the error appears again.

    If this doesn't workaround the problem, do you have a friends machine you can try with? please try to compare each others machines to find what is different? it's possible another 3rd party software which is installed is causing this, maybe your hardware combination has something unique compared to other machines.

    Thanks,
    Chris


  14. Posts
    19
    still nothing, about 3rd party softwr, u mean normal programs or like flash player that loads with windows?


  15. Posts
    19

    screenshot about my programs

    Name:  installed programs 2.jpg
Views: 61896
Size:  98.0 KBName:  installed programs 1.jpg
Views: 62228
Size:  154.2 KB


  16. Posts
    2
    Help error UnityWebPlayer error all verz. Failed to load UNITY dll.

    Geme Battelstar Galactica
    Last edited by PanCibule; 07-08-2012 at 08:40 AM.


  17. Posts
    14

  18. Asset Store Developer



    Location
    Unity HQ, Denmark
    Posts
    22
    Try tracing with Process Monitor (get it here: http://technet.microsoft.com/en-us/s...rnals/bb896645) while reproducing the problem. Process Monitor allows tracing file system activity and will give you more information about what the problem... The trace should allow to see i.e. whether the DLL is not found or is found but fails to load, etc...
    Lasse Makholm
    Asset Store Code Monkey
    Unity Technologies


  19. Posts
    19
    you need a programmer to work with this. you want to do your job....

  20. Cape bearer

    Location
    UK
    Posts
    339
    Quote Originally Posted by alexthan13 View Post
    you need a programmer to work with this. you want to do your job....
    Please don't be rude when we are trying to help you out, we understand this is frustrating, and it's frustrating me that we don't know what causes this, but as I mentioned earlier on in the thread, we need your help, you guys have the specific hardware which exhibits this problem.

    Please try to do any suggestions we make, if you are not sure how to do our suggestions feel free to ask.

    Thanks,
    Chris

Page 1 of 7 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •