Unity Community


Results 1 to 19 of 19

  1. Posts
    13

    Unity 3.5 asset : type == m_TransformInfo.transformType

    After upgraded to unity 3.5, there is a asset occurred when i run my game :

    type == m_TransformInfo.transformType
    UnityEditor.DockArea:OnGUI()

    Assert in file: /Applications/BuildAgent/work/bobcff80449a48aa/Runtime/Filters/Renderer.cpp at line: 251
    The same code is OK in unity 3.4. I have googled it but have no hint. Did any one see this problem before?

    Update:
    I found it may caused by my avatar system, I instantiated a GameObject imported form FBX which only contains bones, mount GameObject with SkinnedMeshRenderer to a bone, then the error occurred. When i inactive mounted object the error disappeared.

    In the release note of Unity 3.5
    Upgrade Guide:
    In 3.5 the behaviour of when to add an extra root node containing imported animation nodes has changed. Previously it was based on if there are multiple root nodes and in order to fix issues where character animation files had only one but the model had multiple, it was using the @ notation files to figure out when to add multiple root nodes. Now the logic is simply: if any of the root nodes have a rigged bone attached or if there are multiple root nodes. This fixes a lot of issues in animations. In some rare cases it might lead to animations not play when importing, they can be fixed by matching the number of bones in the animation fbx file to the fbx file that contains the model.
    Is this problem related to this new features?

    Update:
    Find the reason. when the scale is negative the assert occurs.

    This problem is never occurred in Unity 3.42f, Is this a new bug of Unity 3.5?

    Anyone knows hot to fix?

    Update:
    Represent this bug in 3DPlatformTutorialStart Demo
    1. Open 3DPlatformTutorialStart project
    2. Create a empty scene
    3. Change the default animation (walk) of Lerpz to loop
    4. Drop Lerpz to scene.
    5. Attach fuelCell to anybone of Lerpz
    6. Play
    7. Change the scale x of Lerpz object between positive and negative repeatedly.
    8. The assert occurred.


    Any help would be appreciated.
    Last edited by sonilics; 02-19-2012 at 12:00 AM. Reason: Represent the bug



  2. Posts
    4
    I'm wondering this too. The error I get is caused from having weapon models mounted to the bone of my characters model.

    Any idea how to fix?


  3. Posts
    13
    Not yet, still working on this problem.


  4. Posts
    13
    Update
    Find the reason, but don't know how to fix it.


  5. Posts
    13
    Update
    Represent this bug in 3DPlatformTutorialStart Demo


  6. Location
    Montreal, QC
    Posts
    2
    I have just upgraded my project from 3.4 to 3.5 and am now seeing this error as well.
    I followed the idea of not changing the scale from positive to negative, and this reduced the number of times the error occurred, but I still sometimes see it when playing one animation after another - just a simple Play, and then Crossfade.
    What is the cause of this error?

  7. c'v c'v is offline

    Posts
    1
    Same problem here. Any solution?


  8. Posts
    1
    Seriously? No responses at all?!


  9. Location
    Itajaí, SC - Brasil
    Posts
    2
    I had this same problem with one thin plane with a 2D texture applied to it.
    The problem and the solution I've found, is setting the Scale Z to zero, instead one, this solved the bug in my case.

    Regards.


  10. Location
    Uruguay
    Posts
    2,419
    I get that error when I mess with negative scales D-:
    HEY!... Visit dogzer's Assets Store (;っ˘▽˘)っ (Characters & more)

    Oh, and my Google Plus.
    It has news and stuff! (About games of course)

    "A nerd's work is never done....." (҂⌣̀_⌣́)

  11. I also have this problem after recently upgrading to unity 3.5.4..I have no negative scaling in the scene so this appear to be unrelated..
    I found that the problem was that i had an animated object parented to the skeleton. After deleting it no problem. I have found that I could reattach the animated object to the skeleton after import and it would function fine.
    Last edited by richardzzzarnold; 08-02-2012 at 04:26 AM. Reason: correction

  12. Also having this problem, occurs when scaling a gameObject containing a looped animation in its children such that gameObject.localScale.x == -1f.

    This is happening for us on Windows 7, but not Mac OS 10.6/10.7. What OS are you all on?


  13. Posts
    4
    in my project,
    if the gameobject only has mesh Renderer, it will be ok when the scale is negative;
    but if the gameobject has skin mesh renderer ,i will get this error when the scale is negative.

    mabe the the skin mesh renderer resoult in the error.


  14. Posts
    225
    We have the same problem... Is there any progress on this issue? Has this issue been reported as official bug?


  15. Posts
    3
    We had this issue as well. I will post what I know, in the hopes that it helps others, as well as the workaround solution that I figured out.

    So, we were trying to scale a character with a skinned mesh renderer and some animations to -1 along the X axis. When we played the animation, it would spew errors into the console, for SOME animations. Others played OK, and I don't know enough about the difference between the ones which did and didn;t cause errors to tell you why. However, I was able to work around it using the following:

    So, trying to set the scale to (-1, 1, 1), and rotation to (0, 0, 0). I used the following, and it did not produce errors, and it looked the way I wanted it to:

    scale: (-1, -1, -1), rotation: (0, 180, 180). I assume this could be applied to other axes, but I haven;t tested.

    Good luck all.


  16. Posts
    225
    I would very much like to hear from Unity about this issue. I think everyone will agree. (but not anything like "upgrade to Unity 4.0 and everything will be ok..." like respond...)


  17. Posts
    1
    bump. I'm experiencing this problem too and would really like some kind of response.


  18. Location
    Frankfurt, Germany
    Posts
    124
    NMY - Mixed-Reality Communication GmbH
    http://www.nmy.de

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •