Unity Community


Page 1 of 2 12 LastLast
Results 1 to 20 of 21

  1. Location
    Gold Coast, Australia
    Posts
    3,593

    3.5 Webplayer, ScrollView, MissingMethodException

    I'm using 3.4 latest, but have 3.5 on my system for another client. Sadly the latest web-player [3.5] doesn't appear to like me:

    http://pastebin.com/drYbmVN5

    I have reported this via the in-editor reporter.


  2. Location
    Denmark - Copenhagen
    Posts
    49
    I have this exact problem to! and its live on clients site, have you found any solution? Any help is greatly appreciated!!!

    As far as I can tell this happened after my web player was updated to 3.5, I just cant figure out why this would happen.
    The build that has this problem was built with 3.4.2

    This is from my log:
    System.MissingMethodException: Method not found: 'UnityEngine.GUILayout.BeginScrollView'.

    at SaveLoadInterface.OnGUIDraw () [0x00000] in <filename unknown>:0
    UnityEngine.Debug:Internal_Log(Int32, String, Object)
    UnityEngine.Debug:LogError(Object)
    SaveLoadInterface:OnGUIDraw()
    HUDDrawOrder:OnGUI()
    Last edited by Paul Usul; 02-16-2012 at 10:24 PM. Reason: added more info/stack trace


  3. Posts
    207
    I am having the same error and is already a part of a bug I have reported,


  4. Location
    Denmark - Copenhagen
    Posts
    49
    Quote Originally Posted by gtidhar View Post
    I am having the same error and is already a part of a bug I have reported,
    Awesome!

    Have you found a solution or a workaround?

    I just found out that this is affecting every single player we have built since 2010.
    That's about 9 manufactures, 1 real estate company and a fortune 500..
    That can't log in, save or load any of their data. sh*t

  5. Cape bearer

    Location
    UK
    Posts
    339
    Hey guys,

    Sorry about this one, do you have the case id, so I can investigate this asap?

    Thanks,
    Chris


  6. Location
    Denmark - Copenhagen
    Posts
    49
    Hi, thanks for the attention

    My college is filling out a bug report, I have created a web player & mini-project that demonstrate the simplest form of the bug that I can produce.

    http://lovemyhome.de/test/webplayer/WebPlayer.html
    When you click "Start test" the gui will start drawing a scrollView. It is essential that you supply the scrollView with a style for the bug to appear, can't quite figure out why.
    The "If you can see this message all is okay" text will disappear after the test is started because of null pointers.

    Here is a link to the entire project:
    http://lovemyhome.de/test/webplayerUnityTestProjekt.rar

    All I did was build a web player and enable streaming.
    Also the style uses a picture and has borders in it.

    [Edit]
    Bug does not appear when running web player 3.4.
    Bug does not seem to appear when running a web player 3.5 that was upgraded from 3.2.
    [swap] If the bug does/doesn't occur re-installing web player 3.5 wont/will make it occur.
    Last edited by Paul Usul; 02-17-2012 at 03:51 AM. Reason: more collected info


  7. Location
    Gold Coast, Australia
    Posts
    3,593
    Quote Originally Posted by CreativeChris View Post
    Hey guys,

    Sorry about this one, do you have the case id, so I can investigate this asap?

    Thanks,
    Chris
    443275 for me.

    The workaround for me is simply to remove the scroll-view call [it's on one screen that doesn't need it ATM] - but others may have a harder time. What does surprise me that something as simple as this could get through QA. Maybe a couple more tests need to be added :P

    Quote Originally Posted by PaulUsul View Post
    When you click "Start test" the gui will start drawing a scrollView. It is essential that you supply the scrollView with a style for the bug to appear, can't quite figure out why.
    I just noticed that my calls do appear to have styles or something [ I'm running a modified version of the uLink client script - so my knowledge isn't intimate].

    Code:  
    1. scrollPosition = GUILayout.BeginScrollView(scrollPosition, "Box");


  8. Location
    Unity Technologies HQ, Copenhagen
    Posts
    3,514
    Thank you. We reproduced the issue and will release a hotfix very soon.

    Until then, building your webplayer with Unity 3.5 should fix the issue.
    Last edited by Joachim Ante; 02-17-2012 at 04:52 PM.
    Joachim Ante


  9. Location
    Gold Coast, Australia
    Posts
    3,593
    Quote Originally Posted by Joachim Ante View Post
    Thank you. We reproduced the issue and will release a hotfix very soon.

    Until then, rebuilding your project with 3.5 should fix the issue.
    Good to know - it's nice to see a bug report responded to :P


  10. Location
    Denmark - Copenhagen
    Posts
    49
    Thank you so much! I will sleep a lot better this weekend thanks to that message


  11. Location
    Copenhagen
    Posts
    201
    Quote Originally Posted by Joachim Ante View Post
    Thank you. We reproduced the issue and will release a hotfix very soon.

    Until then, rebuilding your project with 3.5 should fix the issue.
    That is not really a viable option for us as we have 20+ products to upgrade, build, test and deploy.
    Are there by chance any method to force a user to use a specific version of the unity plugin (I know there is with major version, but are there also for minor versions)? If not that would pehaps be an idea for the next release.

    //perlohmann


  12. Location
    USA
    Posts
    163
    I can't explain how glad I am to see this post. I thought I was losing my mind!
    7Moose Games
    Creator of the Conversation Engine

    VDC Madness - (RageSpline and Conversation Engine)


  13. Location
    USA
    Posts
    163
    Any update on this issue? It's a show-stopper for my clients, and upgrading to 3.5 at this time is totally out of the question
    7Moose Games
    Creator of the Conversation Engine

    VDC Madness - (RageSpline and Conversation Engine)


  14. Location
    Copenhagen
    Posts
    201
    Same question as djinni69. Please give an update as soon as anybody know anything.


  15. Location
    Unity Technologies HQ, Copenhagen
    Posts
    3,514
    We are going to ship a hotfix this week.
    Joachim Ante


  16. Location
    Copenhagen
    Posts
    201
    Any news on this? The week is almost over (not counting the weekend). =)

  17. Unity Developer



    Location
    Unity, Copenhagen, Denmark
    Posts
    128
    Quote Originally Posted by perlohmann View Post
    Any news on this? The week is almost over (not counting the weekend). =)
    Hi, the hotfix is released. I'm not sure if you need to download the player or auto update will take care of it.


  18. Location
    Copenhagen
    Posts
    201
    Quote Originally Posted by Kaspar Daugaard View Post
    Hi, the hotfix is released. I'm not sure if you need to download the player or auto update will take care of it.
    Is that something you can find out? it would be nice to know.

    At a first glance it does not look as if the autoupdate takes care of it. 08:50 CET
    When I enter our site the bug is still present. I have tried clearing the cache to see if that should help, but it does not.

    our CTO tested it on saterday at 17:00 CET and at that time the autoupdate seemed to work.

    It works after I manually installed the new webplayer plugin, but I would still like to know if we should spend time on creating alternative solutions for the clients.

  19. Unity Developer



    Location
    Unity, Copenhagen, Denmark
    Posts
    128
    Quote Originally Posted by perlohmann View Post
    Is that something you can find out? it would be nice to know.

    At a first glance it does not look as if the autoupdate takes care of it. 08:50 CET
    When I enter our site the bug is still present. I have tried clearing the cache to see if that should help, but it does not.

    our CTO tested it on saterday at 17:00 CET and at that time the autoupdate seemed to work.

    It works after I manually installed the new webplayer plugin, but I would still like to know if we should spend time on creating alternative solutions for the clients.
    Hi, we are testing making the webplayer auto update to the fixed version. Also we are looking at our process for releasing the web plugin to make these issues less likely to happen, and giving you a priority channel for reporting issues with new players.


  20. Location
    Unity Technologies HQ, Copenhagen
    Posts
    3,514
    Currently the autoupdate does not force update 3.5f5 players. Newly installed webplayers will use 3.5f6 which has fixed the issue.


    We are working on a 3.5.1 hotfix that we are aiming to release next week or the week after. When we ship that, we will force update all 3.5f5 & 3.5f6 players to 3.5.1.


    Until then you can detect the 3.5f5 player from JavaScript and ask the user to reinstall the plugin. The amount of installed webplayers with 3.5f5 is fairly limited. Sorry for the inconvenience.
    Joachim Ante

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •