Unity Community


Page 4 of 10 FirstFirst ... 23456 ... LastLast
Results 61 to 80 of 195

  1. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by proso View Post
    Works like a charm! I've got an issue though, but thats not related to this demo. The pause/resume function in the caption without GUI doesn't work. In the caption with GUI it works perfect!
    Do you know whats wrong?
    Ahh yes that's a bug! We'll fix it in the release. So currently the pause/resume doesn't work in CameraMovieCapture which is the mode that doesn't capture GUI.


  2. Location
    France
    Posts
    7
    Hi,

    Video compression works like a charm with the x264 codec,
    the audio on the other hand causes me some worries.

    Is there a way to configure the audio compression? Cause at this point I don't have the impression it get compressed at all.
    Video compression is doing great, I get about 1 Mb for a minute,
    but when I add sound recording it jumps up to 12Mb...
    which is kind of a dealbreaker for a file that is meant to be sent by mail just after recording is done.

    If you have any ideas or suggestions?


  3. Location
    Manchester, UK
    Posts
    55
    i might be missing a trick here, but i'm trying to record just a section of my screen, i can see i can change width and height of recording....but start position...it's always 0,0. anyway to make it custom.

    Ta.


  4. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by KyleHatch85 View Post
    i might be missing a trick here, but i'm trying to record just a section of my screen, i can see i can change width and height of recording....but start position...it's always 0,0. anyway to make it custom.

    Ta.
    Hi Kyle, I see you're based with us in Manchester Currently SceneMovieCapture only captures the entire screen. Setting width and height sets the output size of the video file. We hope to add section of screen capture in the next release though. If you need it now then you could try using CameraMovieCapture and entering that portion of the screen to a separate camera.

    Hope that helps
    -Andrew


  5. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by Joyrider View Post
    Hi,

    Video compression works like a charm with the x264 codec,
    the audio on the other hand causes me some worries.

    Is there a way to configure the audio compression? Cause at this point I don't have the impression it get compressed at all.
    Video compression is doing great, I get about 1 Mb for a minute,
    but when I add sound recording it jumps up to 12Mb...
    which is kind of a dealbreaker for a file that is meant to be sent by mail just after recording is done.

    If you have any ideas or suggestions?
    Hi Joyrider! There currently isn't a way to configure the audio codec. We've completed the code for this though and it'll be released in the next update. If you would like an early preview I can arrange that. PM or email me.

    -Andrew


  6. Location
    Manchester, UK
    Posts
    55
    my client needs to record a webcam feed that i've placed with unity's Webcam Texture, i was displaying it using GUI.Texture. Thus the reason for using SceneMovieCapture as it does GUI.

    I've working on a work around to display the webcam as a RenderTexture (or GUITexture) not got that far yet, but i'm having the 64kb problem that joyrider had earlier. Was there any news on why that happened?


  7. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by KyleHatch85 View Post
    my client needs to record a webcam feed that i've placed with unity's Webcam Texture, i was displaying it using GUI.Texture. Thus the reason for using SceneMovieCapture as it does GUI.

    I've working on a work around to display the webcam as a RenderTexture (or GUITexture) not got that far yet, but i'm having the 64kb problem that joyrider had earlier. Was there any news on why that happened?
    Hi Kyle, Which codec are you using? Some codecs do give problems with the encoder. X264 in particular I know works best with the 'virtualdub hack' option ticked and 'zero latency mode' ticked. XVid needs to have the 'display encoding progress' option disabled. Let me know which codec you're using


  8. Location
    Manchester, UK
    Posts
    55
    Unfortunately i got pulled onto something else last week. Back on this today. My current setup is a camera and a plane on their own layer. Plane Scaled to 16:9 aspect and the camera rect to the same format. (my webcam is a 1080p) then using the renderer i render the webcam texture onto the plane. I have the CameraMovieCapture script attached to my camera.

    I'm using the x264cfw codec, i've gone into it's settings and ticked the virtualdub hack and zero latency boxes. Still 64kb. Will keep at it this afternoon, report back any findings.

    I will need to playback the video within unity, using AVPro Windows Media asset.


  9. Posts
    27
    Is that possible to record the audio coming out from Unity it self (InGame Audio) and not using external mic or something? I need to record the audio from Unity game and currently I have to select my mic device which could be something like my webcam microphone to record the audio and the quality is really bad.
    Last edited by thetnswe; 12-03-2012 at 06:38 PM.


  10. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by KyleHatch85 View Post
    Unfortunately i got pulled onto something else last week. Back on this today. My current setup is a camera and a plane on their own layer. Plane Scaled to 16:9 aspect and the camera rect to the same format. (my webcam is a 1080p) then using the renderer i render the webcam texture onto the plane. I have the CameraMovieCapture script attached to my camera.

    I'm using the x264cfw codec, i've gone into it's settings and ticked the virtualdub hack and zero latency boxes. Still 64kb. Will keep at it this afternoon, report back any findings.

    I will need to playback the video within unity, using AVPro Windows Media asset.
    Kyle, do the demos included with the asset work? Perhaps work from the demos as I'm not sure why your recording isn't working. We also have a demo that records directly from the webcam in the upcoming release which may help you.


  11. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by thetnswe View Post
    Is that possible to record the audio coming out from Unity it self (InGame Audio) and not using external mic or something? I need to record the audio from Unity game and currently I have to select my mic device which could be something like my webcam microphone to record the audio and the quality is really bad.
    Currently we only support recording from audio input devices on your system and not directly from Unity. Most audio hardware however has a special type of audio input which contains the audio from the speakers. This can be configured in your audio settings and will allow you to record audio directly from the game. We write a bout this in the FAQ section of the plugin documentation. We're working on direct Unity recording though and hope to have the feature in the near future.


  12. Posts
    27
    Thanks for the reply... Does this plugin works inside Unity 4.0? I made a build on Unity 4.0 and the video wasn't rendered correctly.
    Cheers


  13. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by tnswe View Post
    Thanks for the reply... Does this plugin works inside Unity 4.0? I made a build on Unity 4.0 and the video wasn't rendered correctly.
    Cheers
    We will be releasing Unity 4.0 support shortly.


  14. Location
    Glasgow, UK
    Posts
    303
    Version 1.8 with Unity 4.0 support has been released Find it here.


  15. Location
    Glasgow, UK
    Posts
    303
    Hi!

    We have a new version of AVPro Movie Capture that will be released soon which supports: direct audio capture from Unity!

    This means you no longer need to have a sound card that supports 'loop-back' mode to record audio from your game into AVI videos.

    I hope that is good news for people


  16. Posts
    43
    Quote Originally Posted by AndrewRH View Post
    Hi!

    We have a new version of AVPro Movie Capture that will be released soon which supports: direct audio capture from Unity!

    This means you no longer need to have a sound card that supports 'loop-back' mode to record audio from your game into AVI videos.

    I hope that is good news for people
    Thats great!! Keep on doing the good job


  17. Posts
    17
    Hi Andrew,

    There's something weird happening when using the movie capture along with your live camera and quicktime plugin, but maybe not even related with them, I don't know. What happens is that when I press a button to record the movie, the screen goes blank, flickers, goes blank, flickers, goes blank again, then returns to the scene, and starts the capture normally. The flicker is very much noticeable, it lasts a couple of seconds, and it really is annoying. Do you have any idea whatG this might be? The video card is an nVidia GeForce GT 525M. On another PC, (ATI Radeon Mobility HD5470 I think) there is only one small "blink", and the capture starts. It's not as noticeable, but if it's possible to get rid of it, I wouldn't mind.

    Thanks for your support!

    N


  18. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by norbykov View Post
    Hi Andrew,

    There's something weird happening when using the movie capture along with your live camera and quicktime plugin, but maybe not even related with them, I don't know. What happens is that when I press a button to record the movie, the screen goes blank, flickers, goes blank, flickers, goes blank again, then returns to the scene, and starts the capture normally. The flicker is very much noticeable, it lasts a couple of seconds, and it really is annoying. Do you have any idea whatG this might be? The video card is an nVidia GeForce GT 525M. On another PC, (ATI Radeon Mobility HD5470 I think) there is only one small "blink", and the capture starts. It's not as noticeable, but if it's possible to get rid of it, I wouldn't mind.

    Thanks for your support!
    The good news is that I do know what the problem is Basically there's a conflict if you try to use multiple plugins as they all use the samee GL.IssugPluginEvent() message. We're working on a fix for this and should have it out by today or tomorrow. I'll post an update when it's out!


  19. Location
    Glasgow, UK
    Posts
    303
    Version 2.0 is has been released!!

    Changes in this version:

    + Added audio recording directly from Unity
    + Fixed GL.IssuePluginEvent() conflict bug with other AVPro plugins
    + Fixed DX11 recording in Unity 4.0
    + Fixed bug in audio codec listing
    + Renamed and restructured code

    Hope you enjoy the new version


  20. Location
    Glasgow, UK
    Posts
    303
    Quote Originally Posted by norbykov View Post
    Hi Andrew,

    There's something weird happening when using the movie capture along with your live camera and quicktime plugin, but maybe not even related with them, I don't know. What happens is that when I press a button to record the movie, the screen goes blank, flickers, goes blank, flickers, goes blank again, then returns to the scene, and starts the capture normally. The flicker is very much noticeable, it lasts a couple of seconds, and it really is annoying. Do you have any idea whatG this might be? The video card is an nVidia GeForce GT 525M. On another PC, (ATI Radeon Mobility HD5470 I think) there is only one small "blink", and the capture starts. It's not as noticeable, but if it's possible to get rid of it, I wouldn't mind.

    Thanks for your support!

    N
    This has been fixed in the latest release. You'll need to get the latest versions of the AVPro assets you're using.

    Thanks,

Page 4 of 10 FirstFirst ... 23456 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •