Unity Community


Page 1 of 2 12 LastLast
Results 1 to 20 of 23

  1. Posts
    14

    web application failed to download data file

    I tried to create a web application and some testing with unity and javascript communication, however I can't even get the web application to run in the browser. One thing that's annoying is that I'm using FireFox and when I try and load, it just shows a black line, but in Safari it actually shows a message saying "Failed to download data file". There's an error details link, but it just says "Download failed, try again". Not all that descriptive. It's a little frustrating that it didn't work in FireFox, but that's beside the point.

    Does anyone know what this error message really means or some kind of fix? I know it should work right cause I built it to a standalone app and it works just fine.

    You can see what it looks like at:

    http://www.fubarstudios.com/unity/

    Thanks!


  2. Location
    Massachusetts
    Posts
    285
    i get the error.... try making sure that the .unity3d file is in the same directory and has the same name as your trying to call from the HTML.


  3. Posts
    14
    yeah, the file is definitely in the same folder. what's weird is that if i run the html file that's spit out from the build, it works. but as soon as i put it up on a server and try and call it through a domain, it doesn't work. that's really weird to me...i tried to set the src to an absolute path to the .unity3d file, that didn't work either. i would assume that it knows how to deal with relative paths, right?


  4. Posts
    14
    ah ha! i figured it out! it actually had to do with IIS serving up certain file types. i had to manually go in and add the .unity3d extension and mime-type. after i did that, it was good to go. man...stupid windows.


  5. Posts
    17
    Im having a similar issue same message when i upload the HTML and the .unity3d file to my MasterServer.
    When i run it on safari get "Failed to download data file" go check for details it tells me it cannot find the .unity3d file even though both HTML and .unity3d are on same folder.
    Any help?
    Best Regards,
    Hiroz


  6. Posts
    1
    Thanks "wilkinnh".. that does it.
    IIS, by default, was not able to server the .unity3d content. After adding it to the MIME types settings, it worked fine.

    Extension: ".unity3d"
    MIME Type: "application/vnd.unity"


  7. Posts
    4

    adding it to the MIME types settings

    hi friend,

    I have same problem but I colud not solve.
    Coluld you please help me about this problem what do you mean by saying "adding it to the MIME types settings".
    What is MIME settings and how can ı add. Could you tell me?


  8. Location
    Auckland, New Zealand
    Posts
    3,452
    Quote Originally Posted by wilkinnh View Post
    man...stupid windows.
    Not stupid windows, that's an IIS security feature


  9. Location
    Auckland, New Zealand
    Posts
    3,452
    Quote Originally Posted by uboncukcu View Post
    hi friend,

    I have same problem but I colud not solve.
    Coluld you please help me about this problem what do you mean by saying "adding it to the MIME types settings".
    What is MIME settings and how can ı add. Could you tell me?
    Follow this link
    http://lmgtfy.com/?q=iis+add+mime+type


  10. Posts
    4
    hi friend,

    I have same problem but I colud not solve.
    Coluld you please help me about this problem what do you mean by saying "adding it to the MIME types settings".
    What is MIME settings and how can ı add. Could you tell me?


  11. Location
    Auckland, New Zealand
    Posts
    3,452
    Did you follow the link I gave you?


  12. Posts
    4
    Quote Originally Posted by Meltdown View Post
    Did you follow the link I gave you?
    Thanks Meldown you are so helpful


  13. Location
    Auckland, New Zealand
    Posts
    3,452
    Quote Originally Posted by uboncukcu View Post
    Thanks Meldown you are so helpful
    No problem

    Did you solve your problem?


  14. Posts
    7

    failed to download data file error

    One common theme I have found throughout these forums regarding this error is that no one can solve the issue! This error is maddening!

    Same error "failed to download data file"... changed the MIME settings by adding application/vnd.unity as the mime type and both .unity3d .unityweb as MIME extensions. No change, still getting error.
    Last edited by fiddystorms; 03-24-2012 at 07:08 AM.


  15. Location
    QUEBEC
    Posts
    5
    The solution for me was to put this lines code in the same folder of the "*.unity3d" file

    option 1 : create a new "*.txt" and rename it after to "web.config"
    or
    option 2(not tested) : Simply wrote under the </body> of the generated html file from unity player(but dont forget if you do this, you need to rewrote the lines eatch time after the html file was generated. Peraps with the "web.config" you dont need to.)


    /*to use unity3d file extention */
    <configuration>
    <system.webServer>
    <staticContent>
    <mimeMap fileExtension=".unity3d" mimeType="TYPE/SUBTYPE" />
    </staticContent>
    </system.webServer>
    </configuration>

    I'm with a Godaddy hosting on a Windows server (ASP & Apache)
    Last edited by LEO MICHEL; 05-27-2013 at 02:22 PM. Reason: error


  16. Posts
    2

    Other solutions?

    None of the solutions above works. Is there any other way to fix this problem? I am using the Google App Engine, and the error message occurs on both my localhost and the website.


  17. Location
    QUEBEC
    Posts
    5
    The solution I suggest is for unity player, but i dont know about Google native client, sorry!
    Last edited by LEO MICHEL; 06-01-2013 at 07:12 PM.


  18. Posts
    1

    Mini Clip. com game errors

    Quote Originally Posted by wilkinnh View Post
    ah ha! i figured it out! it actually had to do with IIS serving up certain file types. i had to manually go in and add the .unity3d extension and mime-type. after i did that, it was good to go. man...stupid windows.
    Some one needs to tell Mini Clip website creators to look at this, because some games that use this Unity programs like (MOTOCROSS NITRO) aren't working they give that "Fail to download Data pop up." its really pissing lots of players off there.

    just thought I would voice my opinion here, maybe some one from Mini Clip will see this and do something. I will e mail them with this link as well so they can see that they need to change the IIS MIME Domain file name.


    Peace


  19. Location
    Los Angeles
    Posts
    9

    Got it working

    Quote Originally Posted by LEO MICHEL View Post
    The solution for me was to put this lines code in the same folder of the "*.unity3d" file

    option 1 : create a new "*.txt" and rename it after to "web.config"

    <configuration>
    <system.webServer>
    <staticContent>
    <mimeMap fileExtension=".unity3d" mimeType="TYPE/SUBTYPE" />
    </staticContent>
    </system.webServer>
    </configuration>
    This pretty much did it for me. Here are the steps I took that made it work:

    1. Create a text file.
    2. Rename it to "web.config" (make sure the .txt is completely removed).
    3. Copy the above code into the file.
    4. This file needs to be placed in the root directory of your site, not in the same folder as your .unity3d file.

    I hope this clarifies it for everyone. Cheers
    Last edited by hellaandrew; 10-09-2013 at 09:57 PM. Reason: Spelling

  20. Director for Support



    Location
    Unity HQ/UK
    Posts
    1,407
    Quote Originally Posted by PYR0 View Post
    Some one needs to tell Mini Clip website creators to look at this, because some games that use this Unity programs like (MOTOCROSS NITRO) aren't working they give that "Fail to download Data pop up." its really pissing lots of players off there.
    Some one need to tell creators of Unity games who post on Mini Clip website to do more testing. The lack of testing is really pissing lots of players off there.



    Peace

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •